In (k)ubuntu 12.10, I could mount a cifs drive (from my Apple Airport Extreme) with

sudo mount -t cifs -o user=foobar,password=foobar,rw,hard,nosetuids,noperm // ~/mnt/mount_point

This no longer works after my upgrade to 13.04 today. I now get the error

mount error(22): Invalid argument
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I already had cifs-utils installed, and installing smbnetfs did not help. How can I mount cifs volumes in (k)ubuntu 13.04?


I had this same problem trying to mount a Apple Time Capsule volume.

I solved by adding a sec=ntlm option to /etc/fstab.

For your command, use

sudo mount -t cifs -o user=foobar,password=foobar,rw,hard,nosetuids,noperm,sec=ntlm // ~/mnt/mount_point

See a more detailed explanation about the root change in:


Not sure if this is the best solution because I suppose I'm lowering security.

  • 1
    I'm actually trying to mount an Apple Airport Extreme, so it's probably a similar issue. The way I understand it, before this upgrade, ntlm was the default. Now ntlmv2 is the default, so by reverting to ntlm it's no worse security than before. Presumably, the Apple products are not capable of ntlmv2.
    – Sparhawk
    Apr 29 '13 at 0:30
  • @Sparhawk Yes. That edit didn't go through. See askubuntu.com/review/suggested-edits/112619 I understand why you were trying to edit the answer now. Please try to be a little more specific about why you're editing and what you're adding next time ;) .
    – Seth
    Apr 29 '13 at 2:10
  • Okay, apologies for poor communication on my part. I meant to say that this answer does not specifically answer my question, although it does point me in the right direction. I attempted to edit the answer so that it does answer my question. Also, it seems that askubuntu doesn't notify me for failed edits? That doesn't seem like a great feature either.
    – Sparhawk
    Apr 29 '13 at 2:16
  • Also, is the best way to respond to reviewers in the comments of the reviewed question or answer?
    – Sparhawk
    Apr 29 '13 at 2:29
  • +1. I've literally been working on this problem for 2 days. NOTHING worked until this. thank you so much. FYI, working on mounting apple airport extreme disk
    – Katushai
    Nov 18 '14 at 3:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.