After update to 13.04 have broken fonts in gnome terminal:

enter image description here

It is "Ubuntu Mono 13" font, but same spacing problems occurs with any monospace font. What can I do?

  • That's not Ubuntu Mono, chances are you are having problems setting a font on the terminal. In fact that doesn't look like a monospace font to begin with; how are you setting your font?
    – Severo Raz
    Apr 26 '13 at 16:22
  • Yes, that's Monospace font by looks, not Ubuntu. But setted as 'Ubuntu mono'. Font was setted up with Unity Tweak Tool. But same uccurs when I select any monospace font in gnome-terminal's profile settings (actually, there are monospace fonts only available in profile settings). Course, it is possible (and can suppose that is exactly root of problem) there was font's names shuffled after update. Because I have either differencies in text rendering with cyrillic and latin. Apr 26 '13 at 20:50

The same problem had plagued me since my upgrade to 13.04 until I finally found this post:

Fonts corrupted, all look the same

I used Syanptic to determine the unidentified library. The following worked for me.

$ sudo apt-get purge libpango1.0-common pango-graphite
  • Unfortunally I can't check your answer because already did full reinstall. But thank you for your answer. Jun 3 '13 at 9:39
  • I have waited half a year for this answer. It works for me!
    – eccstartup
    Nov 4 '13 at 10:36
  • @IvanZelenskyy It works for me.
    – eccstartup
    Nov 4 '13 at 10:37

After many hours of searching

$ sudo apt-get purge pango-graphite

worked for me. This was broken on a dist upgrade to 14.10, and since I spend 90+% of my time in mate-terminal or gnome-terminal this was truly driving me crazy.


  • 1
    That's the same as the other answer. Nov 23 '14 at 9:19

This is some issue in one of the Graphite libraries. See bug #1166125.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.