12

I have upgraded to Ubuntu 13.04 and I cannot use Unity. I have tried the proprietary driver, both from the official sources and from AMD's website. I have also tried using the open source x.org driver, and under no configuration does Unity start. Xubuntu and Lubuntu configurations start correctly on the same setup. This problem only existed in 12.10 after a kernel upgrade and was fixed by reinstalling the drivers. Reinstalling no longer fixes the problem.

I have also tried purging compiz and then reinstalling unity, and that did not solve the problem.

When I run

unity

I see no errors, but it stops at:

compiz (core) - Info: Starting plugin: session

No more output appears in the terminal. I am currently using the proprietary driver that you install through the update manager (which I accessed with Xubuntu).

So my question is; where can I begin to diagnose the source of this problem, or does anybody have a solution?

28

The old methods of replacing unity no longer work in 13.04. Please try:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reboot if it doesn't work right away.

| improve this answer | |
  • 1
    I ran the first command before and it did nothing, but after running the second command it seems to have fixed the problem after a reboot. Thank you very much. – Clintonio Apr 26 '13 at 0:03
  • Some people felt this question askubuntu.com/questions/285568/… was a duplicate of this one but this answer doesn't do a bloody thing for me. – Josh Pinto May 4 '13 at 5:53
  • works when I run like that dconf reset -f /org/compiz/ && unity --reset-icons &disown at the second time – Claudio Santos Dec 17 '13 at 22:30
1

I had the same problem, but when I tried unity --reset-icons &disown I got the message unity was not properly installed. Never did I uninstall it, but reïnstalling using sudo apt-get install unity fixed this problem for me.
PS: Use Ctrl+Alt+T to open a terminal

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.