Please help me install my AMD ATI Radeon Graphics HD 6770M on Ubuntu 13.04 64bit.

I have Hybrid Graphic card: AMD ATI Radeon Graphics HD 6770M + Intel HD Graphics 3000

My laptop model: HP Pavilion DV6 6050EE

Hardware is listed as supported here: http://wiki.cchtml.com/index.php/Hardware

The laptop fan is always running.

  • Bad Dennis and Brando :(. I did that steps, installed driver without problems and after restarting Ubuntu I got Black screen, and errors about unity. Tried to restart again and the same. Re installed xorg, cleared its settings, no help... re installing. + My system is DesktopPC and ATi 7770. – user152237 Apr 26 '13 at 2:07
  • I've got pretty much the same specs (HP Pavilion DV6 6024) and are suffering from the same problem. I've followed the steps listed here and variations of it listed else where and still I'm greeted with the black 'low graphics' screen. I only want to install this so the machine wont run so hot (it worked with Ubuntu 12.04/Catalyst 12.4) - please help – user152240 Apr 26 '13 at 2:35
  • I have an ATI HD 6570 on an Intel Q45 chipset (with integrated GM4500 video and E8400 core2duo cpu) on which I have installed Ubuntu 13.04 with Catalyst 13.4. After restart (even with sudo aticonfig) the screen is blank. Also tried some things from here: wiki.cchtml.com/index.php/… - didn't work. I am trying to make a HTPC with my desktop. Tried a lot of methods of installing drivers. Either are installed and XBMC is not using video acceleration or I get these annoying black screens. :( – mrjulio Apr 26 '13 at 20:54

1 - Download Catalyst 13.4 from AMD site (previous versions will not work).


2 - Install 32 bit libraries, type the following command on terminal:

sudo apt-get install ia32-libs

3 - Install kernel headers, type the following command on terminal:

sudo apt-get install linux-headers-generic

4 - Install DKMS, type the following command on terminal:

sudo apt-get install dkms

5 - Install Catalyst driver, type the following commands on terminal:

cd Downloads (assuming that the driver is in this folder)

chmod +x amd-catalyst-13.4-linux-x86.x86_64.run
sudo sh amd-catalyst-13.4-linux-x86.x86_64.run

Follow the instructions and reboot the system when asked.

6 - Have fun! :)

  • 2
    following these instructions, I get /usr/share/ati/fglrx-install.log error: /lib/modules/3.8.0-19-generic/build/include/linux/version.h cannot be found... specific headers are installed – mghicks Apr 26 '13 at 3:47
  • I think that is better use generic headers, specific headers gave me problems in the past. – Removed Apr 26 '13 at 4:41
  • 1
    I installed driver as per instructions @Dennis. After restarting the machine I got following error: The system is running in low-graphics mode Your screen, graphics cards, and input device settings could not be detected correctly. You will need to configure these yourself. Unity is not showing, only desktop is showing. Any help would appreciate – UbuntuLover Apr 26 '13 at 6:34
  • Try latest beta instead, it works for my m7670 and support notes include the m6760 as well. support.amd.com/us/kbarticles/Pages/… @Dennis what's with the headers?? – Jack Mayerz May 9 '13 at 9:24
  • 1
    @JackMayerz When specific headers are used they often cause errors when you try to install Catalyst, I don't remember exactly what is the message now, but it's something related with kernel modules. Specific headers sometimes also make your graphics driver break when the kernel is updated. – Removed May 9 '13 at 18:43

This answer worked for my Samsung Chronos laptop which uses Intel/AMD 6750 hybrid : How do I get AMD/Intel Hybrid Graphics drivers to work?

  • This is the one who worked flawlessly for me, even with the newest beta drivers. I have a HP Pavillion G7 1116 SG with a radeon HD6470 / Intel HD3000. – DrA7 Aug 28 '13 at 7:30

You need to enter sudo amdconfig --initial after install and before restarting your system.

Not the answer you're looking for? Browse other questions tagged or ask your own question.