Everything worked fine in 13.04 Ubuntu but then i installed nvidia-drivers-103 Now it does not load into login screen at all. I see blank purple screen during start-up and then just blank black screen appears and nothing happens after.

I booted into recovery mode and removed nvidia drivers, that did not helped. I noticed i had broken Unity environment in recovery mode (no launcher or toolbars, just wallpaper) so i followed :

Unity doesn't load, no Launcher, no Dash appears

where i reseted my unity/compiz back but this did not helped me to boot so finally i installem gdm and now i have compiz and unity fully removed and nvidia drivers too. I still cannot boot, only recovery mode works fine.

What i should try next to have Unity and Compiz happily working ? Which logs should i check and what could be wrong ?

I would expected that unity/compiz is problem but as i still cannot start my OS i guess the reason is much more deeper than i expected. How to restore original version of graphics drivers ? Obviously just removing NVidia drivers did not restored original configuration.

HW : laptop Vostro 3750, Nvidia GT 525M, Intel Mobile HM67 Chipset

  • 1
    Same here, I've got an nvidia geforce G210M and installed one of those newer nvidia drivers. Can't remember which exactly. – Chiel ten Brinke Apr 26 '13 at 16:22

I have a dell Latitude E6500, and got the same problems the only solution I found was the following :

  1. Switch to console mode: Alt+Ctrl+F1
  2. Kill x server: sudo service lightdm stop
  3. Remove nvidia drivers: sudo apt-get remove --purge nvidia*
  4. Generate new xorg.conf file: sudo X -configure -- this will create xorg.conf. A new file in your current dir
  5. Rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
  6. Return to GUI: sudo start lightdm

Of course I would prefer a better solution

  • did not worked for me :/ – Martin V. Apr 28 '13 at 11:37
  • that worked for me at least to remove all nvidia packages on Samsung RV511 – vallllll Jul 6 '13 at 10:01
  • nvidia installation worked for me after doing this, then installing nvidia again, I opted to try installing again, because my x server failed to configure , it said that my screen number doesn't match detected devices (something like that), I also apt-get reinstall xorg before seeing your answer, so it might have to do with either error or success of nvidia reinstallation. also this time i chose not add it to sources when it asks. driver is 319 – Dreaded semicolon Sep 1 '13 at 5:33

I had the same problem on Samsung RC530. Graphics was functional until Nvidia drivers installed which messed up the drivers (I could log in in low resolution, monitor was not recognized at all). I have to say that answer provided by Alain worked. After removing Nvidia drivers in console mode and adding new configuration file everything was back to the old graphics setup.


Solution is to install vanilla Ubuntu 13.04 and do not touch any nvidia / compiz / tweak tools otherwise you will gonna have bad time. Default configuration runs just fine. Before you will try some major changes run clonezilla and save yourselft precious time and do full backup.

If you want to have nvidia drivers (e.g. because of 3d games) i wish you good luck.


I'm on a Dell Latitude E6410 and also get the blank purple screen on bootup.

If I hit the power button, it will then show me a bit of the shutdown but then it stalls. I have been holding onto the power button the power off the laptop. If I boot up a few times, eventually I'll be able to reach the login and usually this means things will continue working (until the next boot).

There's a bunch of what look like kernel Oopses in /var/log/kern.log that seem to coincide with the startup problems. Skimming through it, I see enough "nvidia" and "nv" to think the problem is due to Nvidia drivers or kernel modules.


The built-in drivers on Ubuntu do not require /etc/X11/xorg.conf, but the Nvidia drivers do require it so you will need to create it.

Thankfully, Nvidia provides nvidia-xconfig to do just that.

Create /etc/X11/xorg.conf and reboot to a working system with:

sudo nvidia-xconfig
sudo reboot

The menus and other aspects of Unity including full resolution support for your displays should be restored.

protected by Community Oct 27 '13 at 3:01

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.