Our printer (Brother HL-5340D) does not print correctly on Ubuntu 12.10/13.04. Almost every print-job looks like this:

example of faulty print job

As you can see, the printer is possessed :). Despite that, everything works fine on 12.04 and older versions. The drivers (Brother HL-5350 DN Br-Script3) are the same for 12.04 and 12.10/13.04.

Test-pages are printed correctly. Sometimes we also get an extra page that looks like this:


How can I fix this behavior?


I was hitting this exact same issue today when trying to print PDFs. I was also using the Br-Script3 driver but switched to the Brother MFC9840CDW Foomatic/Postscript driver.

I would rather use the (correct) former driver, but it appears to be an issue that has not been resolved and this is an adequate workaround for my purposes.

  • This fix did not work :(. – dassmann May 24 '14 at 11:12

For us, on Ubuntu 12.10 it wouldn't print anything (not even test page) and would blink red/orange the bottom 4 lights when we tried to print. We resolved it by switching drivers to a generic driver (the linux ones listed on Brother's website 1 did NOT appear to work, maybe I messed up the install) and even double-side printing works now! Ubuntu seems to recognize the printer and automatically add using the Br-Script3 driver. To change it, since I have cinnamon, I went into cinnamon-settings (gnome-control-center does NOT appear to let you change the driver associated with an automatically recognized printer), Printers> HL-5340D > right click, Printer Properties > Settings, Make and Model, Change ... > Select Printer from Database, Generic, Forward > PCL 6/PCL SL > Generic PCL 6/PCL XL Printer -CUPS+Gutenprint v5.2.9.


I have included a screenshot of the appropriate settings. Cinnamon Settings is what you want, on the left/bottom. Gnome-control-center on the right does not work. Actually I don't have enough reputation so instead it is linked 2.


Edit: my friend got it to work without cinnamon by going to localhost:631 and then roughly do the same procedure (select the printer, Administration - Modify Printer, ...).

  • This fix did not work for me :(. – dassmann May 24 '14 at 11:12
  • The web UI worked for me, the Gnome one seems to hang indefinitely while adding a printer. There are some packages with Brother laser drivers and ppd's that may contain the particular model. – XTL Aug 26 '14 at 13:30

I have the HL-5250DN, and I've run across this myself. It's a pain. I haven't had the time (and I usually just use my windows box instead), but you might try one of the HP PCL drivers instead. They've worked for me on Windows when I've had a PC that didn't have the brother drivers installed, and not a lot of time. The older the PCL driver is, the better your chances will be (but fewer features will be supported)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.