In my HP Folio 13 laptop with Ubuntu 13.04 the brightness control works with the slider in the system Brightness & Lock settings, but the brightness function keys don't. Also, the brightness level is set to maximum on every boot.

Is there a way to make them work and make the system keep the brightness level set in the previous session?

Some information about my laptop concering this issue:

ls /sys/class/backlight

ls /sys/class/backlight/*/brightness

lspci | grep -i vga
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)

uname -a
Linux folio13 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64 GNU/Linux

4 Answers 4


I wanted to add a fix that worked for me, because I couldn't find this solution anywhere.

If you have an Intel video card (HD 4000, for example) you can fix it by adding acpi_backlight=intel_backlight to your grub options (in the same way as above).

BEFORE YOU DO THIS: Test that you actually have an Intel video card with the following command:

echo 200 > /sys/class/backlight/intel_backlight/brightness

If your brightness changes, then this solution should work for you.

Please note that I haven't tested this solution for laptops with multiple video cards (like NVidia Optimus or the like).


Guys it worked for me with this setting in /etc/default/grub :


Yep, this is empty value for acpi_osi...

Don't forget to do sudo update-grub and restart after you edit the /etc/default/grub file.

  • Well in my case on pressing Fn + <Brightness Keys> I could see the brightness indicator on the top but brightness wasn't changing at all. I tried what you suggested and after restarting it wasn't even showing the indicator. I removed that line from grub and updated again, restarted and bam! It worked! :) So I guess just running update-grub may solve issue for some. Thanks for that though, I could find a way because of this. :) Jul 27, 2013 at 15:00
  • For me, it reads GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". I tried instead changing GRUB_CMDLINE_LINUX="acpi_backlight=vendor" to GRUB_CMDLINE_LINUX="acpi_backlight=vendor acpi_osi=", but that didn't boot correctly. Instead, GRUB_CMDLINE_LINUX="acpi_backlight=vendor acpi_osi=''" works and also re-enables the wireless switch on the F12 key. That approach seems better than taking the side effects of removing quiet splash from the GRUB command line. Sep 28, 2013 at 18:12

To make the brightness function keys work on my laptop I have tried the following configurations (one by one) in /etc/default/grub, but none of them worked:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor"

Same thing for the GRUB_CMDLINE_LINUX variable.

I read about a solution which suggested editing /etc/X11/xorg.conf, but there was no such file in my system.

So far the best workaround I have found is to use xbacklight to bind the keys to appropriate commands. This will enable you to easily increase/decrease the brightness, but it won't show the brightness indicator while you do that.

1) Install xbacklight by running:

sudo apt-get install xbacklight -y

2) Go into System Settings > Keyboard > Shortcuts > Custom Shortcuts

3) Add the following bindings:

Brightness Down = xbacklight -10
Brightness Up = xbacklight +10

4) Click on "Disabled" and press your preferred combinations (for me CTRL+F2 and CTRL+F3 works fine)


This is a bug that has been recently been addressed: https://bugs.launchpad.net/ubuntu/+source/upower/+bug/994745

It is associated with the upstream kernel bug of problems with unplugging not being recognised: https://bugzilla.kernel.org/show_bug.cgi?id=54621

Hopefully this can be backported to the Raring kernel in the near future.

  • I don't have the power indicator problem which occurs in the bugs you mentioned. It appears though that the patch provided in comment #28 of bugzilla fixes also the two special keys for brightness +/- as well as the wireless adapter toggle. I wonder whether there is an easy way to apply that without having to wait for it to be backported. Apr 26, 2013 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.