I followed this link to install XAMPP on my machine: XAMMP for Linux. I can't open XAMPP in my browser, but I'm getting the 404 errror i.e

Not Found

The requested URL /xampp/index.php was not found on this server.
Apache/2.2.20 (Ubuntu) Server at localhost Port 80

Can anyone help me to find out the error.

  • Btw, you can't access your XAMPP server root at '/xampp/index.php'. You have to type 'localhost' instead. – Томица Кораћ Apr 25 '13 at 11:34
  • Thanks a lot! this command started xampp but however i couldnot access mysql. it says XAMPP: Starting MySQL... XAMPP: Couldn't start MySQL! Anybody has any idea what to do? – user155115 May 24 '13 at 1:45

The command for starting the server is:

$ sudo /opt/lampp/lampp start

Source here:

apache friends - xampp for linux

| improve this answer | |
  • its not working.. we tried it.. some other suggestions please – PYTHON TEAM Apr 25 '13 at 11:14
  • When you say it's not working, what's the response you get when you try to run this command? Are you sure you've installed XAMPP for Linux the proper way, as instructed here: apachefriends.org/en/xampp-linux.html#377 ? Please make sure there is a 'lampp' folder inside your '/opt' directory, and that it contains the script named 'lampp' too. – Томица Кораћ Apr 25 '13 at 11:16
  • its all there in /opt directory.. i m damn sure i installed it.. When i run localhost in my browser i mgetting this message It works! This is the default web page for this server. The web server software is running but no content has been added, yet. – PYTHON TEAM Apr 25 '13 at 11:18
  • Ah, I get you now. The problem is you already have a server software running. You need to stop that first in order to be able to run lampp. For commands how to stop Apache, refer to: cyberciti.biz/faq/… . Then run 'sudo /opt/lampp/lampp start' and tell me what's the response. – Томица Кораћ Apr 25 '13 at 11:22
  • oomsys@oomsysmob-6:~$ sudo /etc/init.d/apache2 stop * Stopping web server apache2 ... waiting . [ OK ] oomsys@oomsysmob-6:~$ sudo /opt/lampp/lampp start Starting XAMPP for Linux 1.8.1... XAMPP: Starting Apache with SSL (and PHP5)... XAMPP: Another MySQL daemon is already running. XAMPP: XAMPP-ProFTPD is already running. XAMPP for Linux started. m getting the same like "already running" – PYTHON TEAM Apr 25 '13 at 11:25

Start command: $ sudo /opt/lampp/lampp start

If you want XAMPP to start automatically when you logon to the system:
Open terminal and run following command sudo gedit /etc/init.d/lampp

paste following code in open file

/opt/lampp/lampp start

save and close the file

run following command to make this script executable
sudo chmod +x /etc/init.d/lampp

run following command to install init scripts to all runlevel

sudo update-rc.d lampp defaults

restart the system

Tutorial link with screenshots: here

| improve this answer | |

This is because, the XAMPP test page is not accessible from the remote clients.
To solve this edit the file /opt/lampp/etc/extra/httpd-xampp.conf.

Note that xampp is installed in /opt/lampp

execute this to edit:

sudo nano /opt/lampp/etc/extra/httpd-xampp.conf

find the line:

require local

then comment it by adding a # at the beginning

#require local

save it

and restart by:

sudo /opt/lampp/lampp restart

Now, you’ll be able to access the XAMPP test page.

| improve this answer | |

It is easy to launch the XAMPP UI Application with:

cd /opt/lampp


sudo ./manager-linux.run # or manager-linux-x64.run

You will then see the graphical interface to manage the server where you can check the ports used.

The Resulting Application UI

| improve this answer | |

Click Home Folder in the launcher, then:

File System > opt > lamp > lampp > lampp.lnk

| improve this answer | |

use this command

cd /opt/lampp
cd /opt/lampp chmod +x manager-linux-x64.run
cd /opt/lampp ./
| improve this answer | |
  • 1
    -1 These aren't even valid commands. cd doesn't take more than a single argument. – David Foerster Dec 18 '15 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.