I just installed a fresh Ubuntu 12.10 and it still keeps asking me for password.

I've spent a few days of searching on net without any luck. I tried loading different drivers, using wicd instead of network-manager, re-configuring router, but still no luck.

There are many threads already about this issue, but none solved my issue. I have a USB wifi dongle Netgear WNA1000M and the driver was installed automatically. Although, when I choose a network to connect to, enter the password, it keeps prompting me for password again.

Cable connection works good.

I've run out of ideas. Can you please suggest further?

Thank you! Lukas

  • Follow the steps in this answer. If it doesn't work, open a terminal (Ctrl+Alt+T) and type sudo service network-manager restart and try again.
    – Alaa Ali
    Jul 14, 2013 at 5:18
  • And if it does not work, try this answer. If any of these solved your issue, let us know which one did.
    – Alaa Ali
    Jul 14, 2013 at 5:24

3 Answers 3


I had this problem. I messed around with drivers and different distros but nothing worked.

I solved it by changing my router settings from n only to g/n.


I had a similar issue.

For me it was causes by the wlan0 power management.


sudo iwconfig wlan0 power off

if that seems to solve the issue you can turn it off permanently:

Create a file in /etc/pm/config.d . I have named it blacklist:

gksu gedit /etc/pm/config.d/blacklist 

and inside the file keep:


How can I prevent iwconfig power management from being turned on?


I had this working for another hotspot (so hardware and network drivers are fine), but failed to connect to the new company WLAN. By comparing the connection information of both, I figured out that

Edit Connections > CONNECTION-NAME > /Wi-Fi Security\ > Authentication
Was on "Tunneled TLS", needs to be "Protected EAP (PEAP)"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.