I am trying to pint to a Brother MFC-7420 from my ubuntu 10.04 machine.

The brother is attached to a windows XP machine and is shared.

This is what I have tried: System->Administration->Printing, Add, Expand Network Printer, Windows Printer via SAMBA, Browse (I can find the printer no problems here), Foward, Choose Driver Dialog, Brother,

My printer is not in this list

So the next thing I tried was to download the printer driver from here http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/download_prn.html

The driver installed fine but my printer still does not appear in the list.

I also tried installing the cups wrapper but that gave the following error.

Restarting Common Unix Printing System: cupsd [ OK ] cp: cannot stat `/usr/share/cups/model/MFC7420.ppd': No such file or directory dpkg: error processing cupswrappermfc7420 (--install): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: cupswrappermfc7420

I tried connecting the printer directly but even though I have installed the driver, when I go to printers and click on the printer (it shows up fine as a USB printer) then it say searching for drivers and then gives me a list, this is the same list as before which doesn't have my printer.

It really shouldn't be this hard. on window you don't have to installing anything it just works and the same is true for my brothers Mac.

How do I print to my printer?

  • Does it work if you plug the printer directly in to the Linux box? Aug 22, 2010 at 14:07
  • I have tried connecting directly and have updated my question with the details.
    – trampster
    Aug 23, 2010 at 0:02

4 Answers 4


You need to do some extra steps, please check this.

You only need to do the Pre-Required Procedure 2, that means opening a terminal and running:

$ sudo aa-complain cupsd
$ sudo mkdir /usr/share/cups/model

Afterwards my test system installed the cupswrapper package and the printer appears on the selection list. I can't test if it works as I don't have that printer.


For my Brother printer (MFC-8380DN), I had to manually enter the printer using the web interface. the url being http://localhost:631/printers. GNOME's CUPS interface failed to produce a test page. The steps necessary are listed here.

I think the crucial step may have been using the IP address notation lpd:// (with replaced by the printer's IP address). I also installed the drivers from Brother's page.


Try this- https://superuser.com/questions/260652/how-do-i-use-my-brother-mfc-7440n-from-debian-or-ubuntu

It uses a driver for a different printer that uses a similar printing engine. It works fine for me on multiple models of Brother MFC.


It is fairly rare to find drivers which match to your exact model. Luckily, most printers are very similar to a lot of other printers, so you can use the drivers for a similar model. Go through the list, find a driver for a similar model. Go for a MFC-7xxx if possible, but any MFC has a good chance of working (I am using the MFC-7840W driver for my MFC-6xxx printer right now). If at first you don't succeed, try again. It really should work without any additional software installed.

EDIT: Make sure you use a color driver if you have a color printer. Iirc a 'W' at the end of the model number indicates black/white, but I could be wrong.

  • Year tried that, but when I print it just prints blank pages forever until I cancel
    – trampster
    Aug 30, 2010 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.