Ubuntu crashed finally after several months (I think it is my hard drive failing). I reinstalled 12.04.02, but all I get is a screen with no launcher icons strip. I am able to change the desktop background, and I have the slidbar to adjust icon size, but it doesn't matter, since I have no icons... If I log in as Guest, I get the launcher strip on the left.I have shut down and started several times, but it is the same. the Guest gets the icons, and the administrator does not. What gives> I am NOT using the hide launcher option. Even so, I tried banging the sides and upper left corner, but no effect.

I am NOT a sophisticated Linux user...


When you are logged in on your administrator account, can you access a tty console by pressing CTRL+ALT+F1? If yes, run sudo apt-get update && apt-get dist-upgrade. When finished, reboot and log in again. If the problem remains, enter the tty console agin and try sudo apt-get install --reinstall unity and reboot again.


First thing you can try is open a terminal by pressing CTRL+ALT+T and type unity --reset. Be patient, this can take a while. If it fails, try to reinstall Unity by typing sudo apt-get update && sudo apt-get install --reinstall unity.

  • thanks. I tried to open a terminal from my administrator log in screen. Nothing happened... no terminal window opened. So... I logged in as guest and was able to get a terminal. It allowed me to run the unity-reinstall command, but that did not correct the problem on my administrator screen. Still no launch bar. I also tried to run the sudo commands on the guest sreen, but I was not allowed. I still can't get launch icon strip on my administrator screen. Any other ideas? Thanks. – Thomas Rayhel Apr 24 '13 at 22:19
  • I'll write another answer. – speter Apr 25 '13 at 9:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.