0

I have at work several xserv doing nothing, and I want to install Ubuntu. I booted from the CD choose Efi and edited the kernel option to add nomodeset so it boots normally.

Then the kernel loaded fine until it hit the Ubuntu GUI installer which gave me unreadable Screen and colors, however I can see the mouse moving and if I hit enter on keyboard the installer jumps to other page in the installation but not readable at all. I tried kernel Options: video=vesa and other video modes But still same! any ideas regarding this?

Screen gets like this:

enter image description here

Another one:

enter image description here

Here is a youtube video of what happens: If I do not add nomodeset the kernel will load halfway thru and freezes at certain point. If I add nomodeset all works fine except the graphics, even on ubuntu server which suppose to be fully cli mode.

Ubuntu Server 12.10 x64 - Xserv 2,1 Early 2008

0

Try nomodeset as a kernel option.

If that fails, try a BIOS-mode boot, if your model supports that (I'm not sure if Apple server models do).

1
  • As I said, I am using nomodeset to boot the kernel. But gets screwes on the graphical installer... – LebLinux Apr 24 '13 at 20:56
0

What you're seeing looks very much like a video driver issue. If you have the option when booting from the CD, skip the Graphical Install and use the command line instead. That may let you install Ubuntu and the proper video drivers load during the installation process.

The other possible issue that pops to mind is, that if the Xserve is using an adapter to connect the monitor (which is what I recall from the Intel Xserves that I used) is that the adapter is at fault. If you have another adapter, switch them out and try again.

22
  • Yes it used a small adapter to take the screen vga cable. But I dont think its faulty because we had installed Mac OsX on the xserv before... But I will try to see if there is an option to go text mode install because the grub2 menu is different then normal one since Xservs boots in efi mode. – LebLinux Apr 24 '13 at 20:59
  • I brought up the adapter because I have seen situations where adapters would be marginally faulty and function on one machine but not another. The option to do a graphical install is on the first screen when booting from the CD IIRC. – douggro Apr 24 '13 at 21:36
  • Hi Again, replacing quiet splash with text does not help. Now trying to install ubuntu server which in deed is a text based installation works, but facing problems while detecting hardware. Its frustrating... – LebLinux Apr 25 '13 at 6:10
  • If it will boot from the Server install CD and show text properly, there's a fair chance the install will work. I would recommend using the 12.04 LTS version of Server – douggro Apr 25 '13 at 11:44
  • I have tried 12.10 server and still check up the youtube video with nomodeset. The video is in the 1st thread. – LebLinux Apr 25 '13 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.