I have a dual boot PC with Windows 7 and Ubuntu. I upgraded from 12.04 to 12.10 and then to 13.04 and since then I have not been able to boot because the PC goes into grub rescue with the error "File not found".

I have tried the following steps:

set prefix=(hd0,msdos5)/usr/lib/grub/i386-pc
set root=(hd0,msdos5)
insmod linux

I get error:

symbol not found : 'grub_realidt'.

if I do insmod normal, I get error

symbol not found : 'grub_disk_dev_list'

I have two partitions containing linux file system: (hd0,msdos5) and (hd0,msdos6). They were mountpoints for / and /boot respectively.

I have searched for this error, and found some "solved" threads. But all of them are using Live USB to get in grub prompt. I don't have access to one, and was hoping to be able to solve the issue without a flash drive.

Please help... Thanks in advance.

  • what is shown when you do ls (hd0,msdos5)/ and ls (hd0,msdos6)/?
    – Rinzwind
    Apr 24, 2013 at 10:33
  • ls (hd0,msdos5)/ shows /boot /home vmlinuz initrd.img ls (hd0,msdos6)/ shows /grub lost+found and many generic image files Apr 24, 2013 at 10:48

1 Answer 1


From Troubleshooting Preparation it should be possible to fix this from command line. But the commands I found are a bit different than you have in your question. So...

  • Do a

    ls (hd0,msdos5)/ 
    ls (hd0,msdos6)/
  • If you see grub then do a set prefix="(hd0,msdos5)/grub" where 5 needs to be changed to correct number.

  • If you see boot then do a

    set prefix="(hd0,msdos5)/boot/grub"
    set root="(hd0,msdos5)"

    where 5 needs to be changed to correct number.

  • After changing prefix you need to do a

    insmod normal

    and reboot.

  • set prefix="(hd0,msdos5)/grub" doesn't work since my *.mod files are not present in this directory for some reason. So, insmod gives file not found error. Apr 24, 2013 at 10:50
  • This is the only method I know and I am afraid you will need a live cd...
    – Rinzwind
    Apr 24, 2013 at 11:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.