10

When I log into my system I have a KDE Wallet password dialog. When I disable it, some passwords as wifi or FTP accounts don't work any more, and the main problem - I dont have "remember password" any more.

For example I disable KDE Wallet, reboot, and I have no KDE Wallet dialog, but my WiFi can't connect, it doesn't ask for password, just "connecting", I give it 10 minutes, then delete (remove) the connection, after recreating it everything is fine.

Please help. Kubuntu 12.04

  • In addition to setting the "All users may connect to this network" as user311982 described (Which I find is only disabled by default for Wifi networks, not Ethernet), which by itself didn't do the trick for me I found the KDE Connection Settings Module, after selecting a Wi-Fi network and navigating to the "Wi-Fi Security" tab: ![](i.stack.imgur.com/gee5V.png) It makes sense that you'd need to choose "Store password for all users" instead of the default "Store password for this user only" so that the password may be accessed before you unlock the – Verax Jan 17 '18 at 15:00
10

I solved this issue by going into the network manager settings by clicking the wifi/network icon in the taskbar > Settings icon, and then from the networks screen that appears, I right-clicked my connection, clicked edit, and then under the "General configuration" tab, ticked the "All users may connect to this network" check box. When I restarted my computer, I wasn't asked to enter the kwallet password and connected to my network automatically.

Perhaps this solution may also solve the problem you are having with kwallet.

  • This should be the correct answer. Well done! – Rymnel May 25 '16 at 15:55
  • For me setting that option and clicking on Apply or Ok is crashing the system settings module . :( – Natesh bhat Nov 9 '17 at 7:37
3

KDE Wallet is the component that does the actual remembering of passwords in a KDE environment.

You could set an empty password, but here’s a suggestion for something to set first: Open KWalletManager and use Settings → Configure Wallet… then untick the checkbox “Close when last application stops using it”. That way, you only need to open it once at system start, then it keeps running and provides you with passwords, while still storing them on disc only in an encrypted form (which it cannot do without a wallet password, obviously).

  • What would be awesome is if KWalletManager would Open on user login, except for non local login. – bksunday Oct 14 '14 at 16:07
  • @bksunday you can do that by using kwalletcli and putting a dummy call, such as kwalletcli -e foo -f bar, into your X session startup files. – mirabilos Oct 15 '14 at 19:45
1

If In doubt, use arch wiki! (https://wiki.archlinux.org/index.php/KDE_Wallet)

1) Install kwallet-pam

2) Edit your display manager to execute pam_kwallet5.so and pam_kwallet5.so auto_start, as a optional auth and a optional session respectively.

3) Profit $$$

0

None of this worked for me but here is how I disabled it (Kwallet) in Plasma 5.

This solved the Wifi issue and Chrome's annoyance - both always requesting a password .... read on - it's kinda simple,

Kwallet Annoyance (Wifi and Chrome) • You can edit file ~/.kde/share/config/kwalletrc - adding to [Wallet] section just one line

              Enabled=false

save quit reboot problem gone - I hope it helps

Mark

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.