I'm a bit new to the Linux world, and my english is bad, so go easy on me ok? ;)

I have just installed Ubuntu 12.10 in my Acer Aspire V3-551-7844 (wich came with Windows8, but after some effort I got rid of that crap), and got this odd issue:

Using the CD, or during installation, or at grub screen, or in Windows7, everything is fine, but when I boot into HD's Ubuntu, the notebook's keyboard and touchpad are completely dead... External usb keyboard and mouse works fine.

I have tried MANY answers about similar issues here and over the web, and updated everything Ubuntu suggested, but nothing works...

Already tried ALL keboard model configurations at System Settings > Hardware > Input Devices > Keyboard, with no effect.

Also, in Touchpad is said: "No touchpad found"...

Any ideas? I really need Ubuntu working.

Thanks in advace!

1 Answer 1


After many hours, I found it!

Open terminal and enter:

sudo gedit /etc/default/grub

Find the line:


and change it to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nopnp=1 i8042.dumbkbd=1 acpi_osi=Linux acpi_backlight=vendor"

Then enter in terminal:

sudo update-grub

That will also solve the problem of screen brightness.

PS: This solution stopped working after updating system to Kubuntu 13.04 (and probably will happen updating to Ubuntu 13.04 as well). Even setting grub back to default, rebooting, changing it again and rebooting, the problem persists.

A simple detail has done the magic, after that: go to System Settings > Input Devices > Keyboard > Hardware > change Keyboard Model to something else > Apply > reboot > change Keyboard Model back to Generic | Generic 101-key PC > Apply > reboot. Done!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.