I am thinking of buying a Wacom Bamboo Pen tablet for drawing with an Ubuntu installation.

I seem to remember there being settings specifically for Wacom in the Settings Manager. Is that still the case? (I am currently not on Ubuntu, so I can't verify).

The searching that I have done have brought up results in threads where people have to do manual setup (editing of config files) to get their Wacom tablets working. Is that the case or is there good support for Wacom tablets (with graphical configuration) in Ubuntu?

  • 2
    WACOM tablets have been supported by Ubuntu for some time now, they work perfectly fine out of the box.
    – Thomas Ward
    Commented Apr 22, 2013 at 19:36
  • 1
    Confirming the success in my Bamboo MTE-450 since Ubuntu 9.04 up to 12.04. Good luck! Commented Apr 22, 2013 at 22:23
  • My Intuos2 tablet has never just worked out of the box on Ubuntu. I got it working on 12.04 with a lot of work. It's broken again on 14.04, and I don't have the time to fight it again. Commented Jan 26, 2016 at 13:47

7 Answers 7


Ubuntu has great Wacom support. It's all plug and play but with great graphical configuration options. You can configure pens and erasers and buttons for all common Wacom tablets. I was even surprised to find that you can lock a tablet to a single monitor in a dual-monitor set-up.

  • you can lock a tablet to a single monitor how?
    – khaverim
    Commented Sep 2, 2021 at 3:41
  • @khaverim Settings -> Wacom Tablet -> Tablet -> Map to Monitor...
    – user2740
    Commented Jan 21, 2022 at 23:52

I know this is an old thread, but I think that the below information is relevant to those with the same question that mydoghasworms had a few years ago.

Wacom support is not really up to scratch in 15.04. Still, you can buy a Wacom tablet knowing that you can get it to work well, though it will take a bit of work. I use a combination of the Wacom Tablet settings in System Settings and xsetwacom to set the buttons on my Intuos4 and Intuos5 to things like hotkeys, modifier keys and toggles (even the ring toggle button works). I have not managed to get the LED displays to work, but I didn't try very hard and others seem to have managed it, and in my opinion, a tablet without those working can still be a killer tablet.

These links will provide very useful information: https://braindump.kargulus.de/?p=432


This one specifically for the correct numbers of the buttons in xsetwacom, that took me ages to figure out: http://ubuntuforums.org/showthread.php?t=1380744&page=32

Personally, I think Ubuntu really has to put a lot more effort into the Wacom tablet setup and configuration tools, but still, get yourself a tablet, it is worth it!

By the way, KDE used to have even more customizability options, including the ability to easily switch between program specific button setups, so you could have a setup for Gimp, and another for Krita for instance. This was great, but those options seem to be gone or not working in Plasma 5.

Good luck!


Sorry but the Ubuntu Wacom Gui tool doesn't offer enough options to fully make use of the device, button (re)mapping e.g is not supported, and and you really want to disable/configure the weird touch behaviour and defaults of the device for working without annoyances, or for using it as a mouse replacement.

I bought a Wacom Bamboo Fun Pen & Touch a few days ago hoping to get full support without googling around for days and getting dirty in the terminal and heavy text editing.. but exactly this is what you have to do, otherwise the device is almost unusable for any serious work. Take that in mind before paying the extra Wacom price compared to other brands. You have to get dirty with text editing anyway, it doesn't matter if you use Arch or Ubuntu, or if you buy a random UC Logic Tablet or Wacom one, to use the device like it should be used a similar amount of self effort is required, and this can put a lot of people off.

If Canonical want artists using other OS switching to Ubuntu, they NEED to make a proper GUI tool for those widespread devices, or artists will return to other operating systems immediately.

If you're comfortable with text editing/scripting, the options to configure the devices are great though.

  • 7
    Why is it Canonical's responsibility, when Wacom provide drivers for other OSes, where tablets don't work at all out of the box? Commented Mar 15, 2015 at 14:48

If you have read the medium wacom article and still confused, don’t worry.Here are easy steps to install wacom tablet in ubuntu

Open a terminal in ubuntu (control+alt+T) and run the following piece of code one by one

sudo add-apt-repository ppa:doctormo/wacom-plus

sudo apt-get update

sudo apt-get dist-upgrade

Download the latest release of wacom from here. On the page, click on release page which will take you to the download pag

Go to the Downloads folder. Go to the input wacom folder

Run the command

if test -x ./autogen.sh; then ./autogen.sh; else ./configure; fi && make && sudo make install || echo "Build Failed"

Restart ur pC

Source- how to install wacom tablet in ubuntu

  • Thanks for the suggestion. sudo add-apt-repository ppa:doctormo/wacom-plus does not seem to work anymore for me unter Ubuntu 19.10. That repo appears not to be maintained anymore. But part of the features of my Intuos BT S seem to work out of the box without any stuff installed, although they do not work smootly. Got to try the new drivers.
    – mfg
    Commented May 15, 2020 at 23:22

Old thread, but still there's very little good info out there. I've never gotten the full features out of my Intuos Pro M (PTH-651) on my Ubuntu 14.04 laptop.

I've managed to get everything to work except for the eraser on the pen and also toggling modes. The LED's change when I press the center button, but it doesn't change the function of the device. Considering how expensive these things are, it's pretty disappointing.

To me, the worst thing is that I've never been able to assign keys using the System Settings>Wacom Tablet GUI. I bring up the menu to map keys, and nothing happens when I highlight a row and hold down a key. So I had to go the hard route, making a script using xsetwacom to launch on bootup.

I also created a launcher, because I found out that if the tablet isn't connected at boot, the script doesn't work. This also applies if I disconnect or reconnect it at any time.

Here's some helpful information for you guys on where to find the key mappings on your system and also a link on how to set things up manually should you need to do so. It was the only thing that worked for me.

The mappings for all supported tablets can be found in the /usr/share/libwacom/ directory. There are text files in the main directory that use a *.tablet extension naming convention. The buttons for the Intuos Pro are designated with alphabetical labels where A=Button 1, B=Button 2, etc. The subdirectory located in /usr/share/libwacom/layouts/ contains vector image files that display a graphical depictions of the tablets and the button assignments. These *.svg files should be opened with Inkscape or another application capable of displaying scalable vector graphics files.

Here's the link I found helpful in creating my script file:


  • First off, a big "Thanks to Bart Van Audenhove for creating the page referenced. Commented Dec 15, 2016 at 5:29
  • Second, what gives with the ccp rip, Linux-Love-Hate? Can't the guy who simplified things for everybody on where to access the mappings get some quote marks? I extracted that info cold-call style; no help other than finding Bart's page for a bit of inspiration on how to make things easier for everybody. I'm ribbing you a bit, because the more people who can contribute or benefit, the better. But to anybody else, skip the bit about brute-forcing your way through figuring out your key mappings and refer to my comment that L-L-H included in their post here. And ignore the 7 upvote answer. Commented Dec 15, 2016 at 5:41

Wacom support in linux depends on several factora. As of today (5/11/2018) there are unsupported models in the market. I bought a One by Wacom (model CTL-472) and it is unsupported in ubuntu 18.04 because the kernel drive shipping with this distro release is not the latest one.

My advice: Stay away from last generation tablets unless you know for a fact that it works.

I compiled the driver, but there are some problems that prevent the tablet from working. Let's hope the first bionic hwe fixes the problem.


Support was very good in 12.10 but 13.04 is partly broken. There are work arounds see http://ubuntuforums.org/showthread.php?t=2139480&page=2&s=773fbf70e6dc15398d100858f0c2ce2e and http://forums.linuxmint.com/viewtopic.php?f=42&t=110408 hopefully this will be fixed soon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .