Initially I realize this isn't going to have all the information needed so one of the first things that would be good is getting advice on how to obtain the relevant debug logs or... how to actually find my terminal now.

I was previously using 12.10 fairly happily, I had some kind of repository update error which initially resulted in being unable to update anything due to (I think i remember this right) some corrupt or missing packages. After a bit of fiddling this all seemed to go away with the exception of a red do not entersign which then hung around in my top right hand unity bar for a while. So I trundled on and happily ignored it all for about a month.

However yesterday, I went to update and something went pretty wrong. To my eye Unity seemed to crash, the launch bar disappeared, the top bar disappeared, Ctrl+Alt+T stopped working. I could bring up a new browser window using the F keys, and later discovered I could take it out of graphical mode to access some form of terminal.

This even went through to the logon screen which held a similar kind of look, but now with incorrect fonts, inconsistent transparencies and apparently highlightable text. Very odd.

I figured I'd uninstalled unity somehow, went out of graphical mode, sudo apt-get install unity (which did in fact appear to be missing). Reinstalled it successfully but then... still won't.

My plan B was to upgrade to 13.04 (i figured this might paste over the cracks I seemed to be working so hard to develop). I managed this, rebooted but the problem persisted.

Launcher has returned now although the dash search seems unable to find the majority of installed programs. Ctrl+Alt+T is still absent (which is the most scary for me as my entire working knowledge of Linux centers around cunningly Googled terminal commands). Gnome appears to be the default choice for browser and top bar.

basically everything looks like this:

enter image description here

can anyone tell me

  1. How I might have managed this (would be nice not to do this again).
  2. what therefore caused it
  3. How to repair it

I'd prefer not to have to reinstall my system as there's files poorly organized everywhere and I'm not sure what I might be nuking.

Also all of the above reoccurs consistently no matter how many times I go about restarting...

A beautiful mess.

  • It seems like there could be a visual theme problem with Unity & GNOME. Have you tried this: askubuntu.com/questions/56313/… and failing that, have you tried sudo apt-get install ubuntu-desktop ? – somoso Apr 22 '13 at 9:34
  • Actually, the best (and first) thing to do is to try pressing CTRL+ALT+F1, log into your account, and type "unity --reset". That should reset Unity to the "out of the box" settings. To get back to the desktop, hit CTRL-ALT-F7 – somoso Apr 22 '13 at 9:36
  • 1
    Thanks somoso, Still got problems but possibly getting somewhere. with CTRL+ALT+F1 "unity --reset" I get the following message: "WARNING no DISPLAY variable set, setting it to: 0" "Error the reset option is now depreciated" – Huw Apr 22 '13 at 9:55
  • My bad, that's how it was in 12.04 (what I've got because stability, yo!). In 12.10 onwards, the reset command is "unity-reset" as I found here: webupd8.org/2012/10/… – somoso Apr 22 '13 at 9:56
  • Ah, terrible debugger that I am I ran two or three 'Fixes' at once and now am unsure which one sealed the deal. I used ALT+F2 to run: "rm -rf .gnome .gnome2 .gconf .gconfd .metacity" and: rm -rf .gnome .gnome2 .gconf .gconfd .metacity .cache .dbus .dmrc .mission-control .thumbnails ~/.config/dconf/user ~.compiz* For good luck... I then went via CTRL+ALT+F1 to do Sudo apt-get install ubuntu-desktop. It appeared to have a lot to do any was installing packages that otherwise didn't appear to be on the system. So. I'm sorted! Thanks for the help Somoso, will remember "unity-rest" in future! – Huw Apr 22 '13 at 10:06

In Ubuntu 12.04, you can fix any unity problems by running

unity --reset

in a terminal. In Ubuntu 12.10 and onwards however, this command is deprecated, and now you must run the following to reset Unity:


I also see you are having trouble getting a terminal open. Linux normally has 4 terminal sessions open when it boots up, and you can access then by pressing CTRL+ALT+F[1 to 4]. To return back to the desktop, press CTRL+ALT+F7.

In that case that doesn't fix your problem, then it could be a GNOME problem. A suggestion here guides you on how to reset GNOME settings to their factory settings and goes into detail how to back them up, so I suggest you follow that tutorial.

If you are still experiencing problems after resetting GNOME settings, then your most likely problem is a missing package of some sort. Try installing the ubuntu-desktop package again by running:

sudo apt-get install ubuntu-desktop

It will install many other packages, but hopefully that should fix your desktop without needing to reformat your OS and starting afresh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.