0

I recently upgraded from Maveric(10.10) to 12.04 (by wiping out Maveric from my system completely) I was using a pen drive, so it messed up my grub. I finally managed to reinstall the grub on the machine and now it boots fine.

Now,I can't download anything from the Software-center or manually. I followed some advice on the forums that included purging the software centre, but once i tried to reinstall, it refused. I checked my software sources they all seem ok. I'm set to main server. I can't install anything.

2

If there is an issue with the software centre, try reinstalling it.

Press CTRL+ALT+T simultaneously to enter terminal.

To uninstall Software Center:

sudo apt-get remove software-center

sudo apt-get autoremove software-center

To re-install Software Center:

sudo apt-get update

sudo apt-get install software-center

If the software centre is working fine, check if the internet connection is working properly.

Press CTRL+ALT+T simultaneously to enter terminal.

Type rfkill list

It should display the lan ,blurtooth and wifi options.If any of it is blocked, enter

rfkill unblock wifi (to correct wifi options).

|improve this answer|||||
  • tried it, but nothing seems to work: – grim Apr 21 '13 at 10:53
1

Open a terminal by going to Applications->Accessories->Terminal

Enter the command:

sudo apt-get update

then

sudo apt-get upgrade

If it gives you any error messages, it will tell you what command to run to fix the error.

Hope this helps!!!

|improve this answer|||||
  • Hi Nefro I tried running the sudo apt-get update command and it returns an error: W: Some index files failed to download. They have been ignored, or old ones used instead. – grim Apr 21 '13 at 11:29
  • Check your added repositories. Maybe some of them are broken. Look at Systemsettings > Software Sources (or Software & Updates, it's called something like that) and then look at "Other Software" – a2r Apr 21 '13 at 11:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.