Everything was OK a few hours ago. I was watсhing some TED video when the sound suddenly just gone to nowhere. I'm not a very experienced Linux user, so I tried to restart the system - it didn't help anyway.

Then I typed


to check out whether PCM and Speaker were turned on. They were. I also tried to update alsamixer to the latest version - it didn't work to. I even tried this "fundamental" way from one russian forum:

sudo apt-get update;sudo apt-get dist-upgrade; 
sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2;
sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop  linux-image-`uname -r` libasound2; 
killall pulseaudio; rm -r ~/.pulse*;
sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`

Didn't help.

What else can I do?

lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

If I can give you more info - please let me know how to get this info and I'll be able to give it to you.

  • Is, after that rather "fundamental" mess up of your system, pulsaudio still running at all? What errors do you see when running pulseaudio in a terminal? – Takkat Apr 21 '13 at 9:19

it is very hard saying what happened to your computer right now. Please try providing more logs. Anyway, Ubuntu's default is pulseaudio and not alsa. So please check your PulseAudio settings (from GUI) whether the pulseaudio sees your hardware and whether it's enabled (and the volume).

1.) You may also try following very basic steps:

  • sudo dpkg --configure --pending

  • sudo apt-get install aptitude

  • sudo aptitude reinstall pulseaudio
  • sudo apt-get reconfigure pulseaudio
  • pulseaudio --start

And this should be not necessary, but the output would be nice to see:

  • sudo service pulseaudio start

Pulseaudio's configuration files are located in /etc/pulse. Here is a link how to restore (missing) config files: https://unix.stackexchange.com/questions/27762/restore-etc-configuration-files-from-the-default

2.) You can also check /var/log/syslog to see whether there are some bad log messages about your hardware...

3.) BTW: Upgrading entire distribution just because of an audio. Next time, please try using this site (askubuntu), stackoverflow site and similar well-known and trusted sources...

4.) You may also try installing alsaplayer and trying playing the sound using this application (it should be using alsa and not pulseaudio).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.