I am having troubles installing the Nvidia driver on my new installation of Ubuntu Gnome Remix (12.10, at first). I would be very grateful if I could receive some help from a kind soul out there.

I have tried the following so far:

  1. Setting nvidia-current and nvidia-current-updates from the GUI
  2. Setting nvidia-current after downloading sources:

    sudo apt-get purge nvidia-*
    sudo apt-get install linux-source 
    sudo apt-get install linux-headers-generic 
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates 
    sudo apt-get update
    sudo apt-get install nvidia-current
  3. Trying the same with this line instead:

    sudo apt-add-repository ppa:noobslab/nvidia-quantal

After the three tries I updated to 13.04 and tried all the same again.

The result is for all cases:

The machine boots into what looks like an old version of Gnome, the screen resolution is very low. when I try to open the nvidia settings I get an error. typing this after installation:

sudo nvidia-xconfig 

does not help.

  • I have a ASUS GeForce GTX 660 2GB PhysX CUDA
  • The system works, but laggs, when I use the nouveau driver.

I will be forever gratefull if someone can help me out, I have tried for a good 7 hours to fix the problem now.

  • Okay, try rebooting after you do "sudo nvidia-xconfig" then go into your software sources or update settings and go to your additional drivers tab. There should be a list of drivers, including the nouveau one and the nvidia one. Try to use the nvidia-experiental version 310 one from there. – user150967 Apr 21 '13 at 8:30
  • I have now tried to re-install 12.10 and done everything all over, but I have still not found a solution. – Vegard Apr 21 '13 at 13:01
  • Try downloading the 310 driver .deb from here and see if it works: packages.ubuntu.com/precise-updates/amd64/… – user151036 Apr 21 '13 at 14:47
  • Hi again, I downloaded the deb and installed it, and to my surprise, the result was not the same. I thought it was the same to use the experimental "apt-get install" and to run the deb, but apparently, its not. But sadly, it did not solve the problem. After I installed and restarted gdm it entered the "simple" version of Gnome, but with normal resolution. I then tried the "nvidia-xconfig", but when I now restarted it was back into the same result as the other tries. Low res, "simple" gnome, no options. I tried installing nvidia-settings again, but that did not work. – Vegard Apr 21 '13 at 16:18

I finally found a solution.

for anyone who faces a similar problem, this is what I did in the end (and what I think was what solved it :)):

sudo apt-get install build-essential linux-source
sudo apt-get install linux-headers-`uname -r`
sudo apt-get install nvidia-current
sudo depmod -a
sudo modprobe nvidia_current
sudo gdm restart

now the system works like a charm.

  • 1
    in ubuntu 12.04 i don't have gdm command.. what is it? – nkint May 7 '13 at 12:49
  • gdm is GNOME Display Manager. the restart is to make the changes take effect. if you use standard 12.04 you can restart with this command: "sudo service lightdm restart" as normal ubuntu uses the lightdm – Vegard Jun 23 '13 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.