I am new in Ubuntu. First I installed Ubuntu 12.10 on my USB stick which is of 16 GB. So, it installed with 2 partitions of 9 GB and 7 GB.

Now I want to format that USB. But when I try to format it, only ext4 one does get formatted but not the partition which is the swap memory. Now on other OS my USB shows only 8.5 GB.

  • Are you booting to a different device than the one you're trying to format / partition?
    – pfeiffep
    Apr 20, 2013 at 13:24

4 Answers 4


Neither of the two existing answers solved my problem.

I needed to go to the Disks app and hit Ctrl-F to get a prompt to actually format the USB drive.

Thanks to this answer.

  • 1
    In Ubuntu 19, now it has been changed to CTRL+D to format a drive and CTRL+P to format a partition in a drive.
    – Mohith7548
    Nov 4, 2019 at 16:50

I know I am late. But hoping this will help somebody. This method is same for every ubuntu versions.

First follow the method 1 in this link to format the usb drive.

I recommend the erase method as slow.

After that your USB drive is formated, but space is now unallocated free space. So you can't use it.

For allocating space you have to click on the + sign below the Volumes bar.

enter image description here

Then enter a name for your USB Drive and click create.

enter image description here

  • you can not format if it is bootable this way. does not allow. still
    – ses
    Oct 17, 2018 at 21:27
  • Never faced a problem with formatting the drive even if it was bootable. Can you pls specify the error message you are getting? Oct 18, 2018 at 2:46
  • This worked for me ...as is Jul 5, 2019 at 18:00
  • 1
    In Ubuntu 19, now it has been changed to CTRL+D to format a drive and CTRL+P to format a partition in a drive.
    – Mohith7548
    Nov 4, 2019 at 16:52

Try gparted - it very good for this

To install it, write next command in Terminal:

sudo apt-get update && sudo apt-get install gparted -y && gksu gparted

After you finished to install it, it will be opened now, choose your usb drive form it and can to format it or remove it and create a new one with your file system that you need.

  • got bunch of exceptions. so disappointed that I can not just format it like it used to be. had to do it two times. then errors have gone. then I still I had a read-only disk. then did it again - format normal way. not very convenient "feature" not letting to format bootable disk.
    – ses
    Oct 17, 2018 at 21:52
  1. Open "Disks" and then select the usb drive
    • You will see the partition table (2mb) for the bootable usb.
  2. Delete the partition of the partition table
  3. Format the usb
  • Like this answer, simple and quick. Works fine on my Ubuntu 18.04 LTS
    – zugzug
    May 17, 2020 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.