1

Problem:- Autocomplete for python not working in eclipse + pydev. Platform:- OS is Lubuntu; Eclipse Version: 4.2.2; PyDev for Eclipse 2.7.3.2013031601

I have configured the pythonpath in "Window->Preferences->Pydev->Interpreter-Python". Under this dialog, in the section called "System PYTHONPATH" I clicked on the right-hand button labeled "New Folder" and added the Folder "/var/libs/python-support". Clicked 'Apply', restarted eclipse. But still python auto completion doesn't work (ctrl+space).

Any suggestion?

Thanks, Vineet
Screenshot of Preferences in Eclipse

  • Can you post a screenshot of the interpreter configuration screen? – Fabio Zadrozny Apr 21 '13 at 0:48
  • I have edited the question to include link for screenshot of preferences in Eclipse. Thanks. – Vineet Apr 21 '13 at 5:53
  • I have the same issue but I have Eclipse Kepler running on MacOs. When I do Ctrl+Space to autocomplete Eclipse becomes 'not responsive' for a while. I added the flag -Djava.net.preferIPv4Stack=true to the eclipse.ini without any positive effect. – user1791567 May 2 '14 at 1:59
0

This is what I found on my end. I had commented out in my /etc/host file the localhost mapping for some scenario I needed to test with GAE and subdomains.

Adding back the mapping (127.0.0.1 localhost) Pydev auto-complete feature started to work again. Weird that I didn't have this issue with Pydev v2. It seems like Pydev v3 does it different.

So, just make sure localhost is mapped in your /etc/hosts file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.