I am really adamant to get Linux running all my games, and I want to make the move to Ubuntu. However, due to the lack of Driver support for both sound and Graphics Cards, I am stuck with Windows.... :(

I've tried to use the drivers provided here: http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx

When I run it from root ./amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run the driver does not install. And there is no update on my system info; saying that the driver was registered successfully.

If anyone here has actually done this on a 4000 series card, can you explain your step by step procedures. Or would it be fair to say that Linux is still not ready for gamers?

Thanks for any help anyone can give.

  • Does fglrx not work? – MiJyn Apr 19 '13 at 18:15
  • Well its not working for me from the instructions i followed online from various websites. :( – Keith D Apr 19 '13 at 18:30
  • just want to make sure, you followed the instructions to install fglrx, and they didn't work? Or are you talking about the installer you mentioned in the post? – MiJyn Apr 19 '13 at 18:32
  • MiJyn, can you point me ro a source of info, or provide the correct steps to installing fglrx properly? Thanks – Keith D Apr 19 '13 at 18:56
  • I've written an answer, see if that works :) – MiJyn Apr 19 '13 at 20:46

There are 4 ways that I can think of for installing/using the radeon driver:

  • Use the built-in open-source version of it (isn't too ideal for gaming though)
  • Use Ubuntu's built-in driver detection & installation tool: Jockey
  • Install the catalyst driver using the 3rd party installer (what you did)
  • Install the catalyst driver in the ubuntu repositories: fglrx

We'll first undo what you did in the 3rd method (very important to do this before anything else), so open a terminal, and run one of these commands (run the first, if it doesn't work, run the second, etc...):

  • sudo aticonfig --uninstall
  • sudo sh ./amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run --uninstall (cd to where that file is located first)
  • sudo sh /usr/share/ati/amd-uninstall.sh

Next, we'll try to use Jockey to install it:

sudo jockey-gtk

Somewhere in the list, this text should appear:

ATI/AMD proprietary FGLRX graphics driver

Select that, then click Activate, and once it's done, reboot, and test it by running:


If it returns No command 'glxgears' or The program 'glxgears' is not installed (or similar), run this:

sudo apt-get install mesa-utils

And then repeat the test. If everything goes fine, there should be a window with gears moving around, and in ~5 seconds, it should report the framerate.

Now if it doesn't work, we'll have to install it by hand:

sudo apt-get purge fglrx
sudo apt-get install fglrx
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
sudo aticonfig --initial

Then reboot. Repeat the test that I listed above, and it should work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.