For the last year, I have been using outdated Shockwave Flash 11.1 r102 in Firefox, because more recent versions (11.2 r202.243 or .280) don't work for me. Typically, with r202 versions, I get blanks instead of Streetview images & YouTube videos. Chromium seems to use whatever flash player I install in FF and its behavior follows FF.

Recently, I started to get awful red warnings about r102 being "vulnerable" (which I believe, of course) & it is disabled & I have to activate it manually every time I want to use it on the above sites.

So in the last few days, I have tried r202 versions again, but they still don't work. I am currently using Lubuntu 12.10 with FF20.0, but I have the same behavior with the same versions of flashplayer in Ubuntu 10.04.

Can I expect any versions to work "normally" in Ubuntu?

  • Not likely. Have you tried using the versions in the repository instead of installing it yourself? Are you 32 or 64 bit? – jmite Apr 20 '13 at 1:42
  • I am using 32 bit. The r102 version which works (but is vulnerable) was obtained by copy-pasting from my 10.04LTS back-up system last year. I obtained r202.243 & r202.280 versions by temporarily installing Flashplugin-installer via Synaptic, then copy-pasting the libflashplayer.so file from /usr/lib/flashplugin-installer to a "safe" folder, then uninstalling flashplugin-installer, then copy-pasting the .so file to /usr/lib/mozilla/plugins. To get r202.243, I had to force the version. So now I have 3 different .so files I can copy/paste into ../mozilla plugins as I like. – user44405 Apr 20 '13 at 8:24
  • I have tried various other methods, like Flash-Aid 2.2.3 (installed but currently disabled), installing flashplugin-installer normally, & following Adobe links, but with rubbish results. I am happy to try any other (preferably GUI) suggestions. To repeat my question - should I expect to be able to see YouTube videos & Streetview images in 12.10? I expect so, but nobody actually said so... Thanks – user44405 Apr 20 '13 at 8:24
  • Well - I have Lubuntu 12.04 on a netbook with Firefox 19.0 & that works OK for Streetview & for YouTube. So that answers my question "should it work?" The flash setup there is Flashplugin-installer & libflashplayer.so is in /usr/lib/flashplayer-installer with links via /usr/lib/mozilla/plugins & /etc/alternatives/mozilla-flashplayer. I tried again to recreate that setup on my troublesome 12.10 Lubuntu, by removing existing libflashplayer.so files & installing flashplugin-installer via Synapt, but that takes me back to no Streetview images etc. – user44405 Apr 21 '13 at 9:59
  • Seems to be a well known year-old Adobe Bug with no fix: bugbase.adobe.com/index.cfm?event=bug&id=3161034 – user44405 Apr 21 '13 at 16:12

I have just downloaded the latest tar.gz file for 64bit linux from adobe.com (version It seems to me that firefox takes the file from /usr/share/ubufox/plugins/, where libflashplayer.so is a symlink to /usr/lib/flashplugin-installer/libflashplayer.so. So I have unpacked the package, and copied libflashplayer.so to /usr/lib/flashplugin-installer/. After restarting firefox, the flash plugin works, it no longer complains. I use Ubuntu 12.04, and I have flashplugin64-installer installed, but I think it does not matter as long as you can find the location of the old plugin. Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.