I've mounted the AOE iso and it seems working. But when I start a game, get an error message "You must insert a game CD to play a single player game, and then restart Age of Empires".

Here is what I've done to mount the iso.

sudo mkdir /media/iso
sudo cp Age_Of_Empire_1/AgeOfEmpireI.iso /media/iso
sudo mount -t iso9660 Age_Of_Empire_1/AgeOfEmpireI.iso /media/iso -o loop
mount: warning: /media/iso seems to be mounted read-only

I dont know whether direct correlation between the setup install directory and the error but this is where the game is installed I think: C:\Program Files\Microsoft Games\Age of Empires

Any help would be appreciated.


Game copy protection mechanisms usually don't work with wine. Download a no CD crack for AOE and try again.

  • 2
    Let me elaborate this a little: While wine really often fails to run copy protected games, also using an .iso CD image will most likely not work, also not under Windows, since .iso only stores the file system but no details about the physical disc. The next thing is, that mounting a CD image, while giving you filesystem access, does not emulate a CD drive, yet many copy protection tools try to talk to the CD drive hardware directly. In order to emulate CD-drive hardware, special software is required. With Linux one can use cdemu.sourceforge.net (with gcdemu as a GUI). – soulsource Apr 19 '13 at 11:37

It's not game copy protection. The first edition of AoE is too old for that kind of safeguard. And, you can mount an iso of the disc in Windows using VirtualClone, and it works just fine on that OS.

What @soulsource said in the comment above made me almost cry. I've burned so many copies of this game because the original one would get scratched, the copy would get scratched or worn out, and I finally just had to resort to using an iso to keep playing it after all these years. I had tried mounting it manually, I had tried using tools to mount it, in Wine it kept changing the drive type back from cdrom to network drive, and the game would complain like the OP said. I tried PlayonLinux, and tried to use their pol script. Nothing worked. gcdemu worked perfectly, though. It mounted it as actual media, Wine was happy, and the game was happy, and I'm so happy. This was the first game I could point to where I felt I was really playing against the computer, and I still love it.

Thank you soulsource for pointing out gcdemu. Please upvote his/her comment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.