1

Sorry for my english. I had installed Ubuntu 12.04 on intel motherboard with atom and igd 3000. On this board two video outputs: d-sub(vga) and dvi. My monitor have only D-SUB. After installation sytem was updated/upgraded and of course rebooted.

BIOS, POST... and black screen.

Some more rebooting... nothing changed.

I had an idea that Ubuntu choose wrong output videoport. Brought from a neighbor another monitor with DVI. And had the ubuntu on the screen.

But in the settings is missing VGA monitor.

Any idea/help?


I have only integrated graphic, and no pci/pci-ex ports

I think need to edit some config to correct video mode. Because on another monitor that has resolution 1920*1080 it works, but on 17" with 1280*1024 not.


After some more manipulation ubuntu had started at 17" monitor. but only once. ANd i can see that ubuntu think that there is two monitors: one is my 17" and another named "laptop". And output in that laptop, all features in setting window is blocked.

I don't know what to do next.


Just reinstall distributive. And step by step watching. Ubuntu see two monitors, one of them is my Samsung connected via VGA, and other called laptop connected via LVDS. But I had only only one Samsung via VGA... and no any LVDS port. So, when i turned off lvds display in settings it turn off samsung.

Ubuntu see my samsung as LVDS connected display with resolution 1920*1280 and show me just a part off Desktop because samsung have maximum resolution 1280*1024. And any changing off resolution of any display turning off video outputs. And if I use xrandr and it options nothing happen.

But this is the other problem, which I think could find in other forums.

  • 1
    Dont's add solved in your title, add your answer as an answer tot he question or accept an answer below. – Alvar Apr 19 '13 at 12:54
  • Thnx, did not know about it – Allivut Apr 22 '13 at 3:53
  • I'd be interested to know how you solved this. – James Bradbury Aug 6 '18 at 15:05
0

You can turn this off in BIOS by pressing F2 / Del / F10 on startup; go to Chipset configuration > Initial display mode > PCi-E and if there is a setting to change shared memory, change it to auto and the onboard graphics will disappear in Ubuntu, so it can only select one.

| improve this answer | |
  • IGD has been previously switched to default. – Allivut Apr 19 '13 at 10:11
  • IGD has been previously switched to default, because motherboard without any pci slots – Allivut Apr 19 '13 at 10:29
  • If it was not configured BIOS I was able to solve it myself. – Allivut Apr 19 '13 at 10:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.