11

Ubuntu Detects 2 monitors when I only have 1. This causes an issue when booting up because it's detecting 2 monitors and by default it is mirroring the display; which is causing a distorted picture since it's trying to create a mirror image on 1 display. xrandr output.... The VGA1 is the phantom monitor and I need to remove it so it boots to LVDS1 and NOT mirrored.

Any suggestions on how to permanently remove VGA1?

:~$ xrandr -q
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
VGA1 connected (normal left inverted right x axis y axis)
1024x768 60.0
800x600 60.3 56.2
848x480 60.0
640x480 59.9
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1920x1080 59.6*+
1680x1050 60.0 59.9
1600x1024 60.2
1400x1050 60.0
1280x1024 60.0
1440x900 59.9
1280x960 60.0
1360x768 59.8 60.0
1152x864 60.0
1024x768 60.0
800x600 60.3 56.2
640x480 59.9 
6
  • xrandr --output VGA1 --off should disable VGA1, xrandr --output VGA1 --auto should bring it back. If this solved the problem leave a comment and I'll add an answer. Otherwise issue lspci | grep -i vga and post the results.
    – Alex
    Apr 19 '13 at 4:54
  • Looks like it didn't work Apr 19 '13 at 16:35
  • root@# lspci | grep -i vga 00:02.0 VGA compatible controller: Intel Corporation 4 Series Chipset Integrated Graphics Controller (rev 03) Apr 19 '13 at 16:36
  • My computer is a Gateway ZX6800 touch-screen Apr 19 '13 at 16:39
  • This is the fix: Edit /etc/default/grub, adding "video=VGA-1:d" between the quotes in the GRUB_CMDLINE_LINUX line sudo update-grub FIXED! Thanks for your help!!! Apr 19 '13 at 17:01
12

This seems to be an issue with certain motherboards that have an HDMI and a Display Port. I figured out that either my Gateway ZX6800 Touch-Screen is using a certain Laptop motherboard with the on-board Intel HD chipset that supports this or it is seeing the IR Blaster or TV Tuner and driving it as a monitor.

Either way the fix is: Edit /etc/default/grub add "video=VGA-1:d" between the quotes in the GRUB_CMDLINE_LINUX line update-grub

Look in /sys/class/drm for a list of your computers outputs.Mine was labelled as "card0-VGA-1". Just remove the "card0-" and that's the name of the output in question.

0
2

I had similar issue with an integrated Intel HD graphics unit (JUSTOP G-PC iA8 Desktop) and missing mouse pointer.

I thought I would add additional help..

to get the correct video to disable...

ls /sys/class/drm

note the name that is similar to the output from

xrandr -q

e.g. my connected (but non existent extra screen was DSI1 in xrandr but card0-DSI-1 in /sys/class/drm)

based on this information the correct kernal data from /sys/class/drm I was then able to correct the syntax in my...

/etc/default/grub

file to read

GRUB_CMDLINE_LINUX="video=DSI-1:d"

then ran

sudo update-grub

and rebooted, now only one HDMI screen connected and working mouse. Hope this helps other people.

1
  • Mine was named eDP-1, it worked tx
    – omisson
    Sep 5 '17 at 22:07
2

Based on the solution of Matthew Aylard above, I checked the connected cards:

ls /sys/class/drm

The output was like this:

card0  card0-DP-1  card0-HDMI-A-1  card0-LVDS-1  card0-VGA-1  card1  card1-VGA-2  renderD128  renderD129  ttm  version

Then I checked

xrandr -q

Turned out in my case, VGA-1-2 was wrongly detected as my second screen which caused the this issue. So, I edited grub configuration file:

sudo gedit /etc/default/grub

And added two lines to disable both VGA-1 and VGA-2:

GRUB_CMDLINE_LINUX="video=VGA-1:d"
GRUB_CMDLINE_LINUX="video=VGA-2:d"

Finally, updated grub:

sudo update-grub

And after reboot, the second "unknown" display which has been there for years, was gone!

1

I have what seems to be a similar problem on pop!_OS (based on Ubuntu 19.10),

Adding "video=VGA-1:d" or "video=VGA-1-2:d" (which what seemed to be connected in the xrandr command) didn't solve it.

I used the Fn+(select screen) function in the keyboard to chose the built in only display. And that solved the issue.

Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.