I'm working on Eclipse Indigo on Ubuntu 12.04.

I'm trying to completely uninstall Eclipse (with Synaptic Package Manager + Mark for complete removal), but when I reinstall it, I clearly see that it has kept all parameters, and history, which is what I'm trying to get rid of. I also tried the following.

sudo apt-get purge eclipse
rm -r ~/.eclipse/

As suggested here, no luck either.

  • 5
    How did you install initially?
    – Mitch
    Commented Apr 18, 2013 at 20:14
  • From the software center, typing "Eclipse". Nothing fancy ;-) Commented Apr 18, 2013 at 20:54
  • Try using a different workspace, after doing a new install.
    – saji89
    Commented Nov 19, 2014 at 8:42

8 Answers 8


Run following commands:

sudo apt-get autoremove eclipse*
rm -r ~/.eclipse/

This will uninstall the dependencies and related packages that were installed along with eclipse. This should do the trick.

sudo snap remove eclipse
  • 2
    Is this valid for Eclipse installed via installer?
    – Suncatcher
    Commented Feb 25, 2019 at 11:44

You were almost done. Add an asterisk (*) at the end of eclipse word.

sudo apt-get autoremove eclipse*
rm -r ~/.eclipse/

Today I have encountered the same problem and searched for a solution. I have seen this question. I have tried the same steps but failed. Then a friend of mine used those commands above.

It removed all about eclipse.


I tried many of the suggested solutions and kept coming up with similar results. Eventually fired up software centre and found that it was registering Elipse as installed. So I installed it through software centre and the process overwrote what was installed already ( probably because I installed via command line).

Then fired up synaptics package manager, did a search for eclipse while sorting by "installed version" column. Selected all dependent packages and marked them for complete removal. That did the trick.


sudo apt-get autoremove eclipse --purge


I would look in the /etc, /usr, and /var directories for any files that may be related to Eclipse. Using the Synaptic or other package managers will only remove files that were part of the installation, not any of the settings files that Eclipse may have made when used.

  • 1
    Depends. If you have manually installed it, this is how you have to do it. But if it is installed through apt-get, this is a bad idea.
    – Anders
    Commented Nov 6, 2014 at 3:35

First remove eclipse:

CTRL+ALT+T, opens up the terminal. Type in sudo apt-get autoremove eclipse.

Now, type in cd / which will put you in the "File System" directory. Next you type gksu nautilus and it will ask you for your password. When you type it in, the File System folder (with all privileges) will pop out. From there you click the search button, type in eclipse, wait for everything to be found and simply delete everything it found.

Then you can go to Ubuntu Software Center and install fresh version of eclipse and add your new packages from synaptic.


I just ran into the same problem today, and managed to solve it with :

sudo apt-get purge eclipse*
rm -r ~/.eclipse/

(Just add a '*' after eclipse) Eclipse is in fact installed as a bunch of different packages, which names all starts with 'eclipse' ; so this should indeed remove all your previous configuration


Using synaptic package manager download "gtkorphan",it will remove your config and a lot of other orphaned packages.After download look in your dash home for Remove Orphaned Packages.I use it religiously to clean up my 12.04 system as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .