10

I am just wondering how to turn off sound at startup? I searched the web, and found a couple of solutions like:

  1. Write "amixer sset Master off" in /etc/rc.local
  2. Use sudo alsactl store

But neither works.

EDIT: I now realize why the amixer command in rc.local doesn't work. This is because the command executes before the alsa driver is loaded. So one solution is to use (sleep 1; amixer sset Master off) in rc.local.

13

One way of doing so is using the Ubuntu Tweak tool. To install it, if you don't have it installed, just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the commands below:

sudo add-apt-repository ppa:tualatrix/ppa 
sudo apt-get update && sudo apt-get install ubuntu-tweak

Once it done, type tweak in Dash, and click on the icon.

enter image description here

When it opens, click on the Tweaks tab, and then Login Settings.

enter image description here

When that window opens, click on Unlock, and then turn Play Login sound off.

enter image description here

3
  • Thanks for the detailed answer! Does it turn off the sound for all applications (mute the speaker), not just the login sound?
    – user69818
    Apr 19 '13 at 5:51
  • As per your question, this just turns off the login sound.
    – Mitch
    Apr 19 '13 at 6:22
  • I now realize why the amixer command in rc.local doesn't work. This is because the command executes before the alsa driver is loaded. So one solution is to use (sleep 1; amixer sset Master off) in rc.local. Combined this with your answer, I am now able to completely mute the system.
    – user69818
    Apr 20 '13 at 19:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.