After using the hack described in : Alps Touchpad on Dell: how do I install the DKMS driver to enable multitouch?, I'm able to get somewhat functional touchpad for a laptop Dell Latititude E6430 using the glidepoint driver.

However, the two finger scroll is somewhat fizzy and definitely not as smooth as in Windows 7. I would be willing to have a try at fine tuning the configuration files (speed of two finger scroll, pressure, that kind of things) to see if I can make it better, but I can't figure out where they are.

The xinput list relevant output is :

⎡ Virtual core pointer                      id=2    [master pointer  (3)]

⎜   ↳ Virtual core XTEST pointer            id=4    [slave  pointer  (2)]

⎜   ↳ GlidePoint Virtual Touchpad           id=13   [slave  pointer  (2)]

⎣ Virtual core keyboard                     id=3    [master keyboard (2)]

and the synclient -l output is :

Couldn't find synaptics properties. No synaptics driver loaded?

The synclient package xserver-xorg-input-synaptics 1.6.2-1ubuntu6 is installed, but apparently doesn't figure out that the glidepoint driver is somewhat of a synaptik-like touchpad that one could whish to configure in a similar way.

The Glidepoint package I installed from the previously mentionned link does have a reasonnably nice GUI config tool, but the only available option for two finger scroll is activate or doesn't activate.

Likewise, the mouse and touchpad system configuration options doesn't give me any tuning related to a touchpad, let alone a multipoint touchpad.

Does someone know how to fine tune the glidepoint driver ?

There is a /etc/glidepoint/configure file which looks like :

target_scancode = 0x4, 0x4, 0x9e    ;event_type, event_code, event_value

ref_scancode = 0x1, 0xbf            ;event_type, event_code

target_scancode_times = 1           ;support 0, 1 or 2

but nothing really obvious here.

I did also locate a ~/.gconf/apps/glidepoint/preferences/ALPS_T3_Touchpa/%gconf.xml file which has an entry :

entry name="TwoFinger" mtime="1365632937" type="int" value="1"/

which looks like it is storing the enabling status of the two finger scrolling configuration but no fine tuning here as far as I can tell.

Note that I'm using Ubuntu 13.04 with standard unity, although I don't see why a non beta distribution would make a difference here (the same happens with Ubuntu 12.04)

Thank you for your answer!

  • this is kind of old, but I have one question though: I have a Dell and the glidepoint touchpad, and scrolling can be done by using the right edge of the touchpad, which is kind of cool I think (I actually prefer this way). Do you have this working? or you simply prefer the two finger method ? Dec 15, 2016 at 14:53

1 Answer 1


I had the same problem on my Latitude 6430u (pre-installed with Ubuntu 12.04) : although the touchpad completely worked (I could even "pinch to zoom") I couldn't configure it.

somewhat solved it by installing a fixed ALPS driver :

  • donwloaded the driver from http://www.dahetral.com/public-download
  • extracted the tarball with tar xvjf psmouse-alps-1.3-alt.tbz and copied all sources to /usr/src with sudo cp -Rvup usr /
  • /usr/src/psmouse-alps-1.3/alps.sh dkms_build_alps
  • I also had to uninstall the debian package "glidepoint"

After rebooting the "touchpad" tab is back in system settings and allows me to configure a perfect two-fingers scrolling. Looks like I lost the pinch-to-zoom but I don't need it...

  • while this doesn't answer the question directly, i am grateful for this answer, as i've struggled with dell's glitchy multitouch driver for 6+ months, and it's unusable, mainly due to speed and insensitivity, and the out-of-the-box driver is jumpy-glitchy. just tried this suggestion and it seems to work great.
    – Simon B
    Dec 3, 2014 at 21:03
  • meh...few days later and the new driver crashes a lot :(
    – Simon B
    Dec 9, 2014 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.