My dual-boot windows 7 / ubuntu 12.04 has been working fine for months, but suddenly i'm unable to boot to windows. i've tried fixing this using boot-repair (i.e. purging and reinstalling grub), but to no avail.

Bootinfo is at http://paste.ubuntu.com/5719132

The specific error i get from grub when attempting to boot windows is:

error: no such device 98E09BBAE09B9CD6
error: no such partition

I've reviewed many similar posts which appear to have been resolved via boot-repair, but again, i've run that several times to no effect.

Any help much appreciated!

  • Just curious, can you mount your windows 7 partition while using ubuntu and navigate it using nautilus? – Nil Apr 18 '13 at 19:11

Try to reinstall grub:

sudo grub-install

When using the grub-install command, the boot information is updated and written to the designated drive, missing - but not corrupted or intentionally deleted - files are restored. Specifically the core.img, grubenv, and device.map are updated and missing modules restored. If missing, the grub folder will be recreated.

The grub-install command does not generate a new GRUB 2 menu (grub.cfg). For this you may run also and this command:

sudo update-grub
  • many thanks for the help. i used the boot-repair tool to reinstall grub and update the grub.cfg, but this didn't resolve the problem. i wonder if there's something idiosyncratic in my partition setup that's preventing the standard fix from working? – wtn Apr 18 '13 at 16:51
  • @duxk.gh You are invited to Discussion between Radu and duxk.gh – Radu Rădeanu May 17 '13 at 14:07

try the following command: sudo update-grub
Normally it should work...

  • thanks for the quick look. tried that also, but grub still returns the same error. – wtn Apr 18 '13 at 16:33
  • Maybe you can try partedmagic at partedmagic.com to see if there's a problem with the partitions. – Ward Segers Apr 18 '13 at 16:36
  • nice tool! checking the windows partitions, they look fine, and oddly, the UUID for the boot partition matches the one grub is trying to load, yet grub says 'no such device' (?) – wtn Apr 18 '13 at 17:10

It's odd that reinstalling grub didn't work. Your Windows distribution shows up on the Grub menu but you get errors when you select it. The only idea I have is to manually add another entry for your windows distribution to the grub menu. Having perused through the Grub 2 tutorial, I think it can be accomplished by doing the following:

Navigate to the /etc/grub.d/ directory and create a new file. The name of the new file should be something like 25_Windows_7. The directory /etc/grub.d contains scripts for adding new items to your grub menu. The order in which these scripts add items to the menu are determined by the number at the beginning of the name. In the file write:

 #!/bin/sh -e
 echo "Adding Windows 7 to GRUB 2 menu"
 cat << EOF
 menuentry "Windows 7" {
 set root=(hd0,1)
 chainloader (hd0,1)+1

replace the occurrences of (hd0,1) with the partition of your windows distribution. I.E. if its sda4 then you would write (hd0,4).

Make the file executable by chmod +x 25_Windows_7.

Now when you run update-grub this new menu item should appear in Grub2's menu.

I have no idea if I even explained it right, but the Grub 2 tutorial can be found here.

  • 1
    thanks much for the suggestion. after some poking around, i discovered that changing the boot order of the disks appeared to resolve the problem. – wtn Apr 19 '13 at 4:28

From my experience and from what I read above, I think it has to do with BIOS settings: I have experienced the same problem today, after a power failure; A BIOS boot mode configuration reverted from "Normal Boot" to "Fast Boot" and the problem showed until I changed it back to "Normal Boot" in the BIOS to solve it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.