3

I have installed powerline and installed the Ubuntu Mono Powerline fonts and selected the font as the font to use in the terminal. The special characters still aren't working after installing the fonts. This is a default Ubuntu install using Gnome Terminal. I have also tried Konsole with no luck. Any other ideas on how to get this font working properly?

  • Yes, I followed the steps. I also tried FontConfig – Chris Johnston Apr 18 '13 at 17:22
  • I sadly cannot comment, but the above method of " moving that to /etc/fonts/conf.d and run sudo dpkg-reconfigure fontconfig to have this new configuration file activated (and logged out and logged in)." did the trick for me. Thanks FvD! – Jay Mar 7 '14 at 20:22
1

Make sure that you are pointing VIM to the powerline bindings folder (it took me a while to understand that by just running the installer, this folder was still not avalailable). In my case I moved the powerline folder to /opt, so in my .vimrc I have a line that:

set rtp+=/opt/powerline-develop/powerline/bindings/vim

The location of your powerling bindings folder is likely to be different

I was unable to have the 10-powerline-symbols.conf recognized in my user folders (even after creating .font.conf.d so I ended up moving that to /etc/fonts/conf.d and run sudo dpkg-reconfigure fontconfig to have this new configuration file activated (and logged out and logged in).

For me that last step did the trick.

One thing you can do to see if all the other parts of the installation went well, is to select the powerline font itself inside vim (or gvim). Although the text will look unworkable, at the very least now the powerline should show the correct fonts. If they do not, then there is something else that needs fixing.

1

Make sure your terminal encoding is set to UTF-8. It can be changed through the profile settings in GNOME Terminal 3.14.2, but if you're using an older version which doesn't have this setting then you need to change your system locale to a UTF-8 locale.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.