1

I am not a fan of the trackpad/touchpad and I want to turn it off while using Ubuntu and I can't figure out how. I have a Dell Inspiron N5110 running Windows 8 with a dual boot option of Ubuntu 12.10.

The Dell Touchpad Properties show:

 "Driver"
Driver Provider:  Alps
Driver Date:  7/12/12
Driver Version: 8.1200.101.209
Digital Signer: Microsoft Windows Hardware Compatibility publisher

 "General"
Device type: Mice and other pointing devices
Manufacturer: Alps Electric
Location: plugged into PS/2 mouse port

In Windows 8 the Fn shortcut is Fn+F3 and that works but in Ubuntu it does not, even though a red box appears in the top right corner indicating it may have. It shows a trackpad icon with an X when the Fn key are pressed.

When I go into system settings, there is only a tab for mouse and nothing for the touchpad.

I've tried several methods listed here and nothing seems to work.

1

The following methods will ensure your changes persist as long as you use gnome:

Using GUI (dconf-editor)

  1. Install and run dconf-editor (if you're on 12.10, dconf-editor might be pre-installed):

    $ sudo apt-get install dconf-tools

    $ dconf-tools

  2. Go to the following settings directory:

    org.gnome.settings-daemon.peripherals

  3. Under touchpad, uncheck the touchpad-enabled checkbox.

Command-line

If you prefer not to meddle with dconf-editor's GUI, run the following command instead:

$ gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled false
  • Using GUI dcon-editor did not work and neither did the command line in terminal. I can not get the thing to turn off. – CatGuyTX Apr 19 '13 at 6:00
  • I guess your touch pad isn't recognized as a touch pad, and was instead recognized as a regular PS/2 mouse. I see you've solved your problem. You should mark your own answer as the solution to your question! – oaskamay Apr 19 '13 at 14:43
1

After making several suggested changes, many of which didn't work. I am very new to Linux and Ubuntu 12.10, I ran across this post, No "Touchpad Tab" under Mouse and Touchpad settings. Detected as PS/2 Generic Mouse

The statement entered into terminal as: sudo modprobe -r psmouse worked. My trackpad is now completely disabled and I am so glad!

  • The command: sudo modprobe -r psmouse works in terminal and it does disable my touchpad. It seems to be detected as a PS/2 mouse but it works. Unfortunately I have to enter this command in terminal each time I start Ubuntu. I will now look for a way to add it to the boot process so it becomes automatic. – CatGuyTX Apr 24 '13 at 1:36
  • I found an answer to turn it off every time as Ubuntu boots. You can try it here. stackoverflow.com/questions/7221757/… – CatGuyTX Apr 24 '13 at 3:56
  • The actual script I used is: sudo modprobe -r psmouse – CatGuyTX Apr 24 '13 at 4:00
-1

Check in the Setting, under Keyboard, Shortcuts. Here you can browse to any number of features and enable them to your chosen key combinations. Trackpad is under System, Hardware.

  • -1 for not reading the question carefully. The OP has mentioned that "When I go into system settings, there is only a tab for mouse and nothing for the touchpad. " Besides, this question has accepted an answer already. – clearkimura Nov 27 '15 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.