37

I need to use sshpass to launch a remote command through SSH from a Java code.

If I manually type in a console:

ssh -p 22 user@ipaddress mplayer '/media/data/myFavouriteSong.mp3'

works perfectly, but asks for password. So I tried running sshpass:

sshpass -p mypass ssh -p 22 user@ipaddress mplayer '/media/data/myFavouriteSong.mp3'
sshpass -p mypass ssh -l user@ipaddress mplayer '/media/data/myFavouriteSong.mp3'
sshpass -p mypass ssh -t user@ipaddress mplayer '/media/data/myFavouriteSong.mp3'
sshpass -p mypass ssh user@ipaddress echo 'OK'

and none of them work.

7
  • Did you setup passwordless login? Password-less logins with OpenSSH debian-administration.org/articles/152
    – koni_raid
    Apr 17 '13 at 8:52
  • I'd rather stick to sshpass, due to the inconvenients of enabling password-less login in an enterprise
    – Roman Rdgz
    Apr 17 '13 at 8:57
  • Did you try this: sshpass -p 'mypass' ssh username@server.example.com
    – koni_raid
    Apr 17 '13 at 9:13
  • I did, doesn't matter if i use 'mypass' or mypass. It starts waiting forever
    – Roman Rdgz
    Apr 17 '13 at 9:22
  • sshpass -V works?
    – koni_raid
    Apr 17 '13 at 9:38

10 Answers 10

39

This may be caused by the host-key checks done by ssh. It looks like sshpass keeps silent on invalid host keys (no output on neither stderr nor stdout) and exists with status-code 6. At the time of this writing, this was revision 50, and the matching constant in the code is RETURN_HOST_KEY_UNKNOWN, which hints to that error.

Your error-code may differ and looking at the code linked above may give you some insight.

If your issue is an invalid host-key you should think twice about overriding the error with a CLI option. Your machine could be compromised or you may be subject to a MITM attack! If you are 100% certain that this is not the case and if you have no means to keep the verified host-keys up-to date, you can use a command like this:

sshpass -pfoobar ssh -o StrictHostKeyChecking=no user@host command_to_run
11
  • 2
    With the brew install, a space is needed after -p. github.com/hudochenkov/homebrew-sshpass Dec 21 '16 at 0:43
  • 1
    NOTICE: Everyone should remember that it is more secure to use passwordless SSH Host Keys whenever possible! By definition, using SSHPass is less secure. Jun 7 '18 at 13:45
  • @Questionmark while that is true, there are edge-cases where the remote endpoint does not support authentication via key. Which is where sshpass comes in handy
    – exhuma
    Jun 8 '18 at 11:42
  • Yes, I know. That is why I said "whenever possible"... Jun 8 '18 at 14:11
  • 1
    With new enough SSH, there's StrictHostKeyChecking=accept-new.
    – muru
    Oct 3 '18 at 4:25
10

sshpass command works only if the password prompt ends in assword:.

If your password prompt is different you may have to adjust the source code of sshpass to recognize the prompt you have.

I have seen password prompts like Password for user@host: on some systems, maybe this is your problem.

3
  • 2
    sorry? -P prompt Which string should sshpass search for to detect a password prompt
    – m3nda
    Oct 29 '17 at 6:34
  • 4
    This new option (needs at least V1.0.6 of sshpass) solves that problem.
    – rjs
    Nov 2 '17 at 10:48
  • Oh, sorry. This kind of issue (solution?) happen so often, old questions that are already fixed at new versions. Thanks.
    – m3nda
    Nov 2 '17 at 21:05
3

I think you want something like:

sshpass -p yourpassword ssh user@ipaddress somecommand

For instance, this works for me:

sshpass -p mypassword ssh username@10.0.0.9 touch foo
1
  • if pass contains all type of special characters then it will not works Jan 15 '20 at 13:33
1

There is lots of way to do that, here is my suggested solution:

First of all, storing your password in a variable is give you more flexible commands. sshpass has an option for that:

-e: this option allows to read password from $SSHPASS environment variable

You have two way to set this variable:

  1. Set directly in your code:

    export SSHPASS='your_pass'
    
  2. Or ask for it:

    readPassword () {
      echo Ssh Password: 
      read -s SSHPASS
      eval "export SSHPASS='""$SSHPASS""'"
    }
    
    # read password
    
    readPassword
    

Than execute your command;

  1. If your command is static, run it directly:

    sshpass -e ssh user@host << EOF
    mplayer '/media/data/myFavouriteSong.mp3'
    command2 parameter1 parameter2 parameter3 ...
    command3 parameter1 parameter2 parameter3 ...
    ...
    EOF
    
  2. If your command will be dynamic use like this:

    DYN_FILE_LOC='/media/data/myFavouriteSong.mp3'
    
    eval 'sshpass -e ssh user@host << EOF
    mplayer "$DYN_FILE_LOC"
    command2 parameter1 parameter2 parameter3 ...
    command3 parameter1 parameter2 parameter3 ...
    ...
    EOF'
    

hope this helps someone.

4
  • In your readPassword function, can't you just do export SSHPASS?
    – kutschkem
    Apr 20 '15 at 11:13
  • @kutschkem, I trust but my idea that i think here; i dont want to write my pass in a static file but instead of writing password again and again for lots of servers(7+), i write once :) You don't have to use readPassword function, you can just write your password, it should work :) Only i want to share my code which is shows an example using sshpass for dynamic commands :D Apr 20 '15 at 12:07
  • No, I just mean that the eval is not necessary after the read, export does not need an assignment. ss64.com/bash/export.html
    – kutschkem
    Apr 20 '15 at 12:35
  • the problem with -e is that the export will be listed in your history
    – ejaenv
    Mar 5 '18 at 21:29
1
  1. make a key

    ssh-keygen -t rsa

  2. make a .ssh folder on the remote server it will ask for a password

    ssh $USER@SEVERNAME mkdir -p .ssh

  3. copy the key to the remote server

    cat .ssh/id_rsa.pub | ssh $USER@SERVER 'cat >> .ssh/authorized_keys'


Check if it asks for a password, if not it should work.

ssh $USER@SEVERNAME 'command'
0

sshpass uses pseudo terminals and the man page includes apologies for breaking occasionally. You can also try fd0ssh. It works if you do not need to send stdin to a process on the remote machine. That works if you just issue a command and capture the result.

0

sshpass syntax is

sshpass [-ffilename|-dnum|-ppassword|-e] [options] command arguments

Note that there is no space between the -p and the password.

Also I've noticed that you have to connect with ssh at least once manually to obtain the RSA key of the machine you are connecting to, to go into the ~/.ssh/known_hosts file before sshpass will allow you to connect.

so after obtaining the entry in the known_hosts file I can run a command such as

sshpass -ffilename_with_password_in_it ssh user@server uname -a

and it will execute the command uname -a on the remote server and output the results to the standard out on the local machine.

0

What you need is -f -t -t -t

sshpass -p$PASS ssh -f -t -t -t $USER@$HOST $COMMAND

Additionally you might have to remove "requiretty" from sudo config (/etc/sudoers) on the remote machine.

0

@exhuma had an example that lead to it working for me.

The password needs to be in form of -pPassword (without the space)

also quotes may be necessary: sshpass -p'Password&0' user@hostname

0

The simplest usage is to set the SSHPASS variable:

read -p "SSH password:" SSHPASS
export SSHPASS

Then you can run e.g.:

sshpass -e ssh $user@$host echo Test

If something is going wrong, the -v flag will give you more information.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.