3

When I try to run in Terminal:

sudo apt-get install phablet-tools android-tools-adb android-tools-fastboot

It gives the response:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package phablet-tools
1
2

Try:

sudo apt-get update
sudo apt-get upgrade

and than you can try install packages again.

3
  • Danke! Sorry, I'm new to this. Also sorry if my english is hard to understand. :)
    – user149869
    Apr 16 '13 at 21:32
  • 2
    not working for me
    – McLan
    May 13 '14 at 14:21
  • The version in the archive is always stale, and not maintained. always grab from the ppa, as mhall119 recommends Feb 1 '16 at 13:24
2
  1. Ensure the universe archive is enabled. You can do this by appending "universe" to the lines in /etc/apt/sources.list which contain " trusty " and " trusty-updates "
  2. sudo apt-get update
  3. sudo apt-get install phablet-tools
2

I am struggling with this myself - Note that there is a no-longer (in 2016) updated version of the phablet-tools package in trusty/universe. Use the PPA instead.; you need to download them from here; https://launchpad.net/~phablet-team/+archive/ubuntu/tools/+sourcepub/5673076/+listing-archive-extra - The trouble is I do not know where you should extract them to......

UPDATE

I spent lots of time trying to make this work; in the end I gave up - got an old machine, installed precise (which has Phablet-tools etc in its universe repository) - or does it? - I am still struggling with the phone installation

Update 2

Still struggling with this; The instruction page here https://developer.ubuntu.com/en/phone/devices/installing-ubuntu-for-devices/ says Note that there is a no-longer updated version of the phablet-tools package in trusty/universe. Please use the PPA instead.

So I installed Precise on an old machine

however; here it says phablet-tools for precise have been deleted.

It seems whatever I do I cannot achieve this. I will keep digging and post an update.

I could do with a plan B because this is driving me nuts...

UPDATE 3

Went back to try with Trusty; in trying to install phablet-tools as suggested above I get

The following packages have unmet dependencies. ubuntu-device-flash : Depends: click-ubuntu-policy but it is not installable Depends: ubuntu-snappy-cli but it is not installable `

2

You need to install the phablet PPA in order to get phablet-tools:

$ sudo add-apt-repository ppa:phablet-team/tools
$ sudo apt-get update

And then install the phablet-tools:

$ sudo apt-get install phablet-tools

See https://wiki.ubuntu.com/Touch/Install for the full instructions

1
  • did not work for me
    – McLan
    May 13 '14 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.