In Mythbuntu 12.04.2, ALSA (1.0.25+dfsg-0ubuntu1.1) fails to recognize the A88GMV on-board AMD 880 HD Audio (card).

This system is fully updated.

The system also contains a NVIDIA graphics card (GeForce 8400 GS) with NVIDIA HD Audio controller (rev a1) and a motherboard on-board HD 4250 graphics controller (disabled in BIOS).

This system was formerly connected to audio amplifier via HDMI then to HD display.

After loss of the HD display, the NVIDIA 8400 was connected to a Asus VW246H via DVI and the audio was changed to connect to the on-board mini-jack 5.1 external speakers. The BIOS audio settings were AMD 880 HD Audio (disabled-sets audio out on on-board HDMI) and HD Audio Controller (enabled-previously disabled). These settings worked with the dual-boot Win7.

There was no audio when running Mythbuntu 12.04.2. ALSA (alsamixer) reported only the NVIDIA 8400 GS built-in audio (HDA-intel), not the ATI on-board AMD 880 HD Audio.

lspci reports both cards:

00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 3c)
00:14.1 IDE interface: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 IDE Controller
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller
00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge
00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS] (rev a2)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)

From ALSA Information Script v 0.4.61:

!!Soundcards recognised by ALSA
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfcf7c000 irq 19

!!PCI Soundcards installed in the system
00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)
01:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)


!!Modprobe options (Sound related)
snd-atiixp-modem: index=-2
snd-intel8x0m: index=-2
snd-via82xx-modem: index=-2
snd-usb-audio: index=-2
snd-usb-caiaq: index=-2
snd-usb-ua101: index=-2
snd-usb-us122l: index=-2
snd-usb-usx2y: index=-2
snd-cmipci: mpu_port=0x330 fm_port=0x388
snd-pcsp: index=-2
snd-usb-audio: index=-2
snd-hda-intel: probe_mask=0x102

and also:

!!ALSA/HDA dmesg
[   23.442280] cfg80211: 2474000 KHz - 2494000 KHz @ 20000 KHz), (600 mBi, 2000 mBm)
[   23.447440] snd_hda_intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   23.447444] hda_intel: codec_mask forced to 0x2
[   23.457977] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   26.316757] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   26.480043] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x100f0000
[   27.332070] wlan0: authenticate with 00:18:f8:f9:63:74 (try 1)
[   27.350482] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[   27.488061] hda-intel: Codec #1 probe error; disabling it...
[   27.520036] hda-intel: no codecs initialized
[   27.520142] snd_hda_intel 0000:00:14.2: PCI INT A disabled
[   27.520343] snd_hda_intel 0000:01:00.1: PCI INT B -> GSI 19 (level, low) -> IRQ 19
[   27.520346] hda_intel: Disabling MSI
[   27.520347] hda_intel: codec_mask forced to 0x2
[   27.520366] snd_hda_intel 0000:01:00.1: setting latency timer to 64
[   27.760052] HDMI status: Codec=1 Pin=5 Presence_Detect=0 ELD_Valid=0
[   27.760139] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:01:00.1/sound/card0/input7
[   27.960225] init: mythtv-backend main process (1964) terminated with status 127

Other info:

!!Kernel Information
Kernel release:    3.2.0-40-generic
Operating System:  GNU/Linux
Architecture:      x86_64
Processor:         x86_64
SMP Enabled:       Yes

!!ALSA Version
Driver version:     1.0.24
Library version:    1.0.25
Utilities version:  1.0.25

!!Loaded ALSA modules

!!Sound Servers on this system
      Installed - Yes (/usr/bin/pulseaudio)
      Running - Yes
ESound Daemon:
      Installed - Yes (/usr/bin/esd)
      Running - No

Full ALSA Information Script v 0.4.61 report here. (http://pastebin.com/EAaDqrFE)

Web search suggests replacing ALSA with OSS or edit /etc/modprobe.d/alsa-base.conf, both of which I am disinclined. (see this)

  • Note: The product manual states the audio uses a Realtek ALC887 chip. – keepitsimpleengineer Apr 16 '13 at 18:22

Well, I solved the problem and this is how I did it

  1. Download and burn iso for Mythbuntu 12.04.2
  2. Boot system to change BIOS to use builtin video & boot from DVD(CD)
  3. Remove the NVIDIA graphic adapter
  4. Insert burned the 12.04.2 iso into DVD
  5. Reinstall 12.04.2
  6. Kill the automatically open/fail Mytbuntu Front end (due to database version missmatch)
  7. Use Mytbuntu Control Center to set version to 0.26 from the install default 0.25 and enable repositries.
  8. Perform massive apt-get update/dist-upgrade
  9. Use alsamixer to enable the builtin audio (HDA-ATI-SB with it's Reactek ALC887 chip.)
  10. Used PulseAudio VolumeContol to set devices and volume (Device 0 was audio)
  11. Finished installing and set the settings for front-end.
  12. Shut down and re-installed NVIDIA graphics adapter.
  13. Rebooted, changed graphics adapter selection in BIOS and installed drivers for NVIDIA.

Note: Strange occurance, the fully updated 12.04… fontend/backend uses kernel 3.2.0-40-generic while the new frontend install uses kernel 3.5.0-27-generic.

Now the built-in sound (card) is recognized by ALSA and audio works well.

Note: The 12.04.2 kernel is different that 12.04.1, see here to update the 12.04.1 to the 12.04.2 kernel.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.