I turned to Ubuntu 12.10 (and then Mint...and then back) as a means for giving one last leg to an old PC. I'm thrifty, and thought Ubuntu's UI was very attractive. As it stands, I love how Ubuntu functions, I love how it looks, and I'm pretty sure I could become a pretty loyal user...but.

I'm having one hell of a time getting any online movie rental service to work. I'd rather avoid any torrent options, so the services I've attempted to use include:

  • Amazon Instant Video
  • Vudu
  • Blockbuster's Service (Cinema...something)
  • Google Play
  • iTunes (via Wine/PlayOnLinux)

From what I can tell, the only common thread with these services is DRM. Here's what I've attempted to make these work:

Here's what happens when I currently try to use the various services:

  • Amazon: Player loads (Green progress dots...looks fine); Then I receive a Play Update prompt that says "An error occurred and your player could not be updated. This is likely because your Flash Player or Browser needs to be updated.This update is required to play back the video."
  • Vudu: The player loads, then I'm given an endless buffering status. Sometimes the buffering status drops off, but the video never loads.
  • Blockbuster thing: The player gets hung up on loading a video.
  • Google Play: Static and "Please Upgrade Flash to Watch this Video"
  • Can't get any version of iTunes to install correctly through Wine.

I just want one of these services to work, I really don't care which one. Ubuntu will never be able to become my primary OS if I can't rent a movie on it from time to time...which I think would be a shame. So hopefully there's one of you brilliant Ubuntu-ers (what do you call yourselves, anyway?) who can figure this out.

If you need system specs, error logs, or whatever, just ask (but you might have to tell me how to pull them). I've gotten fairly comfortable with punching in various Terminal commands, though I don't know what I'm doing most of the time.

As an aside, please don't recommend any of the subscription services at this time (Netflix, Redbox Instant, Hulu---Hulu does play video for me btw). I may turn to those at a later date, but I prefer to rent movies on the fly at random. Now that I think about it, just in case it helps you, I can get video to play from:

  • Hulu
  • YouTube
  • ABC

And I haven't tried any others beyond that...

  • That looks like some pretty thorough review of the state. +1 I will be watching this for some solution to my viewing needs. Stuck with MacOSX for the same reason. – DrSAR Apr 16 '13 at 6:48
  • As far as I know it is bit hopeless with no Flash updates for Linux, Googles Pepper not supporting DRM on Linux and of course there is no proper Silverlight with DRM implementation for Linux either. I ordered small and cheap android on stick for watching movies because of that..will see how that works out. – Tanel Mae Apr 17 '13 at 15:25
  • Thank you guys for chiming in, at least I feel a little more sure about the situation. Perhaps we'll see some progress in this area from Ubuntu's future releases. – Layton Apr 22 '13 at 1:58

Manual creation of some directories and such have to be done with HAL as outlined in these answers.

Is there a work around to get protected Hulu or Amazon Prime instant videos working?

p.s. i run CentOS 6 and it was fixed on its own by Amazon within a week.

| improve this answer | |
  • The instructions on that link worked! Thank you! – Layton May 4 '13 at 22:17
  • For clarification: I can now play videos on Amazon Instant Video, Vudu, and Google Play. I did not attempt with the other services listed above because I really was only interested in the three that are now working. I have updated to 13.04 since initially posting this question. – Layton May 4 '13 at 22:31

Try Using Chrome. It has full flash support, which should help with both google play and Amazon. iTunes doesn't really run well in wine, if it runs at all. http://appdb.winehq.org/objectManager.php?sClass=application&iId=1347 . I'm not sure what Vudu and Blockbuster use, But as long as they use flash Chrome is your best bet. Also, make sure you install the newest versions of icedtea Java (6 and 7) From the Ubuntu Software Center.

| improve this answer | |
  • Thank you DJ Hedgie, but I've already tried different variants of Google Chrome. Chromium, Chrome, Chrome Beta, and Chrome on Wine. I've taken what steps I can to disable "pepper" from it as well. I will double check on Java though. – Layton Apr 26 '13 at 21:58

Get a copy of Android and install it in a Virtualbox VM. It will have the DRM built in.

| improve this answer | |
  • And you'd be amazed what you can find by going to Twitter and typing "putlocker [movie name goes here]". ;) – Volomike May 3 '13 at 6:32
  • 1
    Thanks Volomike, I forgot to mention I had tried this method as well, and yes it works, but I wasn't overly excited with the quality. I used a desktop build of Jelly Bean, and many of the video apps I tried didn't want to install/cooperate. Also, the aspect ratio didn't line up too well. To be fair, I only spent an hour or two playing with this solution, so I probably could have tweaked it to my liking or tried alternative builds of Android. Again, thank you for the comment. – Layton May 4 '13 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.