0

Using 12.04 32bit; trying to setup Canon ip2600 printer.

When I try to install the Canon driver apt-get refuses to install it, instead replaces "libcupsys2" with newer "libcups2" creating a dependency problem since the Canon requires "libcupsys2". I have tried the standards: sudo apt-get update, sudo apt-get clean, sudo apt-get autoremove, sudo apt-get update && sudo apt-get upgrade, sudo dpkg --configure -a, & sudo apt-get install -f but none make the printer work

I followed instructions at: http://ubuntuforums.org/showthread.php?t=1427098 to change the dependencys but that did not help, it generated error messages. Printer state is still: "idle - /usr/lib/cups/filter/gstoraster failed"

At this point I am wondering if I should "apt-get remove" the cups package.

Any help would be appreciated

1

After trying many things I finally stumbled onto this page which solved my problem: http://www.ppsolution.net/en/articles/linux/ubuntu_driver_printer_canon_ip2600.pdf

I used the shell script method and the printer installed with no problems. They have not only the explanation of the problem but the solution. They deserve some "attaboys".

-1

I just installed Ubuntu on an Acer Aspire circa 2010 and a ThinkPad X61. I spent several hours trying to get my Canon Pixma iP2600 to work with advice from several sites. Some wanted me to type many terminal commands. None worked. Finally found this one, it’s simple, and works perfectly: http://handytutorial.com/install-canon-printer-driver-for-ubuntu-13-04-12-10-12-04/.

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Danatela Mar 31 '14 at 2:27

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.