2

I'm using MATE 1.6 from the official MATE APT repo.

I've tried enabling Compiz using the following steps, based on this guide and adapted for MATE 1.6:

  1. Open dconf editor
  2. Go to org.mate.desktop.session.required-components
  3. Change windowmanager from marco to compiz
  4. Relogin

However, when I relogin, I have no window frames and no Compiz plugins. I've tried compiz --replace in a terminal, which gives no errors, only logs of it loading plugins.

3

MATE 1.6 will not work with Compiz, the change from Mateconf to Gsettings broke it. Use MATE 1.4 if you want to use Compiz with MATE

| improve this answer | |
  • can you explain why compiz doesn't work with 1.6? – strugee Apr 16 '13 at 23:04
  • 1
    Read through the MATE forums, you will find the confusing answers of the devs there. Seems MATE using Gsettings is not able to communicate with compiz anymore thus it will not find window decorators and compiz plugins. I tried MATE 1.6 with Compiz 0.8.8, as soon as compi geht's kicked in I lose all panels and end up with a dysfunctional system. – Jeannie Apr 17 '13 at 9:33
  • Somehow when I upgraded from 1.4 to 1.6 it imported my Compiz settings, and although it was glitchy at the first one or two logons, I'm using MATE 1.6 with wobbly windows as of now. In dconf I have at org.mate.session.required-components --- windowmanager=compiz. I have tried Compiz Fusion Icon but it crashed with 1.6. – Mike C. May 9 '13 at 2:39
  • 1
    You also have to make sure that the relevant plugins are enabled in CompizConfig Settings Manager, such as Window Decoration (mine is with command gtk-window-decorator --replace), Window Move, Window Resize, and of coarse Cube rotation. – Mike C. May 13 '13 at 2:54
5

Just tried this and worked for me:

  1. Use Synaptic or Apt in terminal (sudo apt-get install) to install the following packages: compiz, libdecoration0-dev, compizconfig-settings-manager, compiz-plugins Do not bother to install install the fusion-icon package, Compiz Fusion Icon doesn’t work anymore in Mate 1.6

  2. To set-up compiz to start automatically at login go to Start-up Applications (from Control Centre and add a new entire (click add) and write "Compiz" to name and enter "compiz --replace" in the command field (without the quotes). For manually start use command "compiz --replace" in terminal.

  3. Replace "marco" with "compiz" windowmanager to lower the CPU usage. Do this with dconf Editor (install it first). Navigate to org > mate > desktop > session > required-components > windowmanager, click on “marco” and modify it. You can use also next command in terminal: sudo gsettings set org.mate.desktop.session.required-components windowmanager compiz

  4. Open CompizConfig Settings Manager and be sure you ticked “Window Decoration”, “Move Window”and any other functions you may find useful.

  5. Go to General section, check "Gnome Compatibility", open it and go to Commands tab and replace (in all 3 command lines) the word "gnome" with 'mate". Go back and test this: press Prt Sc key. Now you can take a dessktop screenshot.

Activating composition you may experience some freezing or resets of the X system due to the video card. Tray to change your video driver. Works for me.

Source: http://community.linuxmint.com/tutorial/view/1298

| improve this answer | |
  • what was missing for is libdecoration0-dev, also I got fooled and didn't realise everything in compiz-settings-manager was turned (window decoration, desktop wall, move window, application switcher) - its all working now, cheers – Daithí Nov 26 '14 at 8:38
3

I know you have already marked an answer, but I was having the same problem as you and found a solution. All you need to do is:

sudo apt-get install compiz-gnome

This installs gtk-window-decorator for you which is used by compiz to draw the window borders. Logout and log back in and you'll see you have window decorations again :)

Worked for me on Linux Mint 15 Olivia Mate.

Considering Mint 15 is based of Ubuntu 13.04, this shouldn't be hard to perform on Ubuntu ;)

| improve this answer | |
  • If someone tries on Ubuntu I'll accept this answer. – strugee Oct 10 '13 at 21:16
  • 1
    @strugee, just tried this using Ubuntu 14.04, and it does not work. Or at least, it doesn't just automatically work as described in this answer. I have Mate and compiz-gnome installed, and so far Compiz does not work in Mate. – Questioner Jul 13 '14 at 2:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.