This question already has an answer here:

I installed 12.04 Desktop because I want the option to run Unity in the future, but I PREFER to work headless via SSH.

I changed the following in /etc/default/grub:


changed to:


Rebooted and still get the graphical Unity interface

changed the above to:


Rebooted and again, no love -- still get the Unity interface.

I see that /boot/grub/grub.cfg is generated automagically by grub-mkconfig using templates /etc/grub.d and /etc/default.

I saw that my first option in grub still read thusly:

menuentry 'Ubuntu, with Linux 3.5.0-27-generic' --class ubuntu --class gnu-linux --class gnu --class os {
    gfxmode $linux_gfx_mode
    insmod gzio
    insmod part_msdos
    insmod ext2
    set root='(hd0,msdos1)'
    search --no-floppy --fs-uuid --set=root c40e42d6-6e01-4abf-b2e3-e46132dcfa0a    linux   /vmlinuz-3.5.0-27-generic root=UUID=3a07789f-f0b4-4123-a26a-6f245ef9054e ro   quiet splash $vt_handoffeneric
    echo    'Loading Linux 3.5.0-27-generic ...'
    linux   /vmlinuz-3.5.0-27-generic root=UUID=3a07789f-f0b4-4123-a26a-6f245ef9054e ro recovery nomodeset 
    echo    'Loading initial ramdisk ...'
    initrd  /initrd.img-3.5.0-27-generic

Note that it still reads 'quiet splash' above (single quotes mine). So I ran grub-mkconfig to see if that was needed to re-build grub.cfg from /etc/default/grub, but even after running that, 'quiet splash' persists.

Can anyone advise on where I'm going wrong? I just want my bash...


marked as duplicate by Jorge Castro, Eric Carvalho, Warren Hill, BuZZ-dEE, Lucio Apr 9 '14 at 17:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.


Change the line:


GRUB_CMDLINE_LINUX_DEFAULT="quiet splash text"

then update grub:

sudo update-grub and reboot.

  • Yep, Stef, the key part that I neglected is really embarrassing, as I usually RTFM and it clearly states in /etc/default/grub, "Run update-grub after making any changes" So, your answer is great and "noquiet nosplash text" is just what I wanted. And to future users, RUN sudo update-grub !!!!! – Todd Curry Apr 15 '13 at 23:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.