I've been trying to install Ubuntu 12.04 (64-bit) on my ASUS N75SF laptop, but Ubuntu can't get to the point of installing. It hangs immediately after entering the first purple screen ( the one where there is only the universal access picture which equals to a keyboard). It doesn't report any errors at all, even after being hanged for around an hour, then I downloaded Ubuntu again from a different source and put in on another CD, with no success. I also tried using the 32-bit version of 12.04 but it also hangs at the same point, while both versions of 10.04 work normally in Live-CD mode (haven't tried installing them). I updated my BIOS to the latest version available ( BIOS 214 from ASUS support page). I tried to see if Windows 7 (64-bit) installs, which it does, but i didn't go through with it. Currently, there is no OS installed on that machine, with the whole HDD formatted into two partitions via Hierns tools. One partition is ext4 and the other is NTFS if it means anything. AFter following the instructions on other similar topics, I got stuck at the point that they say I should turn off acpi_osi= and nomodeset but i can't enter grub and BIOS doesn't have such options.

ASUS N75S specs: Intel HM65 Express Chipset Intel Core i7- 2670qm cpu 8 GB RAM NVIDIA GeForceGT 555M 2GB 2.5" SATA 750GB 7200rpm

PS: I have a around 6 months of experience with Linux and have some knowledge on the Linux CLI. Additionally, I've installed Ubuntu 12.04 6 times before on 6 different machines, without any problems.

Edit: I checked the bios settings. UEFI is disabled, but i can't seem to find the option for Secure boot/CSM and fastboot.

  • 1
    I decided to try out other distro's until i could find a fix for this issue. So far I've tried Fedora 18, which has the same issue. Linux Mint 14, on the other hand works like a charm, except for Nvidia Optimus, but I am currently working on that. – nixhitchhiker Apr 17 '13 at 13:57
  • did you resolve that issue? I had a similar problem with an asus, maybe that was the correct way to you, too: askubuntu.com/questions/519610/… – feligiotti Sep 30 '14 at 15:32

has that pc secure boot enable?


If that doesn't work, feel free to ask me to swap your useless pc with mine! ;)


You need to disable intel anti-thief tech from the bios/uefi (I had the same issue with an asus n750jk and when i disable the anti-thief thing the ubuntu installer worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.