I downloaded the unity-greeter-13.04.1 from https://launchpad.net/unity-greeter. Now I want to compile it to able to install it on my Ubuntu 12.04. But I face below problems while compiling:

hejar@hejar-Studio-1555:~$ cd '/home/hejar/Downloads/unity-greeter-13.04.1' 
hejar@hejar-Studio-1555:~/Downloads/unity-greeter-13.04.1$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking for valac-0.18... no
checking for valac-0.16... /usr/bin/valac-0.16
checking /usr/bin/valac-0.16 is at least version 0.15.1... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking whether make supports nested variables... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
checking for UNITY_GREETER... no
****configure: error: Package requirements (
    liblightdm-gobject-1 >= 1.4.0
) were not met:****

Requested 'liblightdm-gobject-1 >= 1.4.0' but version of liblightdm-gobject is 1.2.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables UNITY_GREETER_CFLAGS
and UNITY_GREETER_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


I tried sudo apt-get build-dep unity-greeter command then re-tried the ./configure but it did not work. Even I tried the sudo apt-get install --reinstall lightdm, then sudo apt-get install --reinstall unity-greeter, and then sudo gedit /etc/lightdm/lightdm.conf and chnaged the code as "greeter-session=unity-greeter" and from terminal run sudo dpkg-reconfigure lightdm and from there choose "lightdm" as given in the forum http://ubuntuforums.org/showthread.php?t=2096409.

Still stuck. Can anybody help? Is there any command that can show me broken programs or packages? Is there a PPA for this to resolve?

Actually I am not an expert and so far I got this:

hejar@hejar-Studio-1555:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0.orig.tar.gz --2013-04-14 22:04:51-- https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0.orig.tar.gz Resolving launchpad.net (launchpad.net)..., Connecting to launchpad.net (launchpad.net)||:443... connected. HTTP request sent, awaiting response... 302 Moved Temporarily Location: https://launchpadlibrarian.net/118426353/lightdm_1.4.0.orig.tar.gz [following] --2013-04-14 22:04:52-- https://launchpadlibrarian.net/118426353/lightdm_1.4.0.orig.tar.gz Resolving launchpadlibrarian.net (launchpadlibrarian.net)..., Connecting to launchpadlibrarian.net (launchpadlibrarian.net)||:443... connected. HTTP request sent, awaiting response... 200 OK Length: 660979 (645K) [application/gzipped-tar] Saving to: `lightdm_1.4.0.orig.tar.gz'

100%[======================================>] 660,979 378K/s in 1.7s

2013-04-14 22:04:54 (378 KB/s) - `lightdm_1.4.0.orig.tar.gz' saved [660979/660979]

hejar@hejar-Studio-1555:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.diff.gz --2013-04-14 22:05:14-- https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.diff.gz Resolving launchpad.net (launchpad.net)..., Connecting to launchpad.net (launchpad.net)||:443... connected. HTTP request sent, awaiting response... 302 Moved Temporarily Location: https://launchpadlibrarian.net/119217989/lightdm_1.4.0-0ubuntu2.diff.gz [following] --2013-04-14 22:05:15-- https://launchpadlibrarian.net/119217989/lightdm_1.4.0-0ubuntu2.diff.gz Resolving launchpadlibrarian.net (launchpadlibrarian.net)..., Connecting to launchpadlibrarian.net (launchpadlibrarian.net)||:443... connected. HTTP request sent, awaiting response... 200 OK Length: 49509 (48K) [text/plain] Saving to: `lightdm_1.4.0-0ubuntu2.diff.gz'

100%[======================================>] 49,509 105K/s in 0.5s

2013-04-14 22:05:17 (105 KB/s) - `lightdm_1.4.0-0ubuntu2.diff.gz' saved [49509/49509]

hejar@hejar-Studio-1555:~$ wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.dsc --2013-04-14 22:05:36-- https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.dsc Resolving launchpad.net (launchpad.net)..., Connecting to launchpad.net (launchpad.net)||:443... connected. HTTP request sent, awaiting response... 302 Moved Temporarily Location: https://launchpadlibrarian.net/119217991/lightdm_1.4.0-0ubuntu2.dsc [following] --2013-04-14 22:05:37-- https://launchpadlibrarian.net/119217991/lightdm_1.4.0-0ubuntu2.dsc Resolving launchpadlibrarian.net (launchpadlibrarian.net)..., Connecting to launchpadlibrarian.net (launchpadlibrarian.net)||:443... connected. HTTP request sent, awaiting response... 200 OK Length: 1806 (1.8K) [text/x-debian-source-package] Saving to: `lightdm_1.4.0-0ubuntu2.dsc'

100%[======================================>] 1,806 --.-K/s in 0s

2013-04-14 22:05:38 (15.3 MB/s) - `lightdm_1.4.0-0ubuntu2.dsc' saved [1806/1806]

hejar@hejar-Studio-1555:~$ tar xzf lightdm_1.4.0.orig.tar.gz hejar@hejar-Studio-1555:~$ gunzip lightdm_1.4.0-0ubuntu2.diff.gz hejar@hejar-Studio-1555:~$ patch -p0 < lightdm_1.4.0-0ubuntu2.diff patching file lightdm-1.4.0/debian/lightdm-session patching file lightdm-1.4.0/debian/lightdm.upstart patching file lightdm-1.4.0/debian/liblightdm-gobject-1-dev.install patching file lightdm-1.4.0/debian/lightdm.prerm patching file lightdm-1.4.0/debian/guest-account patching file lightdm-1.4.0/debian/source_lightdm.py patching file lightdm-1.4.0/debian/compat patching file lightdm-1.4.0/debian/copyright patching file lightdm-1.4.0/debian/lightdm.config patching file lightdm-1.4.0/debian/rules patching file lightdm-1.4.0/debian/changelog patching file lightdm-1.4.0/debian/liblightdm-gobject-1-doc.install patching file lightdm-1.4.0/debian/lightdm.pam patching file lightdm-1.4.0/debian/lightdm.postinst patching file lightdm-1.4.0/debian/lightdm.dirs patching file lightdm-1.4.0/debian/lightdm-greeter-session patching file lightdm-1.4.0/debian/lightdm.preinst patching file lightdm-1.4.0/debian/lightdm.install patching file lightdm-1.4.0/debian/lightdm.init patching file lightdm-1.4.0/debian/lightdm.templates patching file lightdm-1.4.0/debian/lightdm.lightdm-greeter.pam patching file lightdm-1.4.0/debian/liblightdm-gobject-1-0.symbols patching file lightdm-1.4.0/debian/liblightdm-qt-2-dev.install patching file lightdm-1.4.0/debian/gir1.2-lightdm-1.install patching file lightdm-1.4.0/debian/lightdm.postrm patching file lightdm-1.4.0/debian/control patching file lightdm-1.4.0/debian/watch patching file lightdm-1.4.0/debian/liblightdm-gobject-1-0.install patching file lightdm-1.4.0/debian/liblightdm-qt-2-0.install patching file lightdm-1.4.0/debian/lightdm.lightdm-autologin.pam patching file lightdm-1.4.0/debian/po/tr.po patching file lightdm-1.4.0/debian/po/sk.po patching file lightdm-1.4.0/debian/po/de.po patching file lightdm-1.4.0/debian/po/ca.po patching file lightdm-1.4.0/debian/po/it.po patching file lightdm-1.4.0/debian/po/ru.po patching file lightdm-1.4.0/debian/po/pl.po patching file lightdm-1.4.0/debian/po/pothead.in patching file lightdm-1.4.0/debian/po/da.po patching file lightdm-1.4.0/debian/po/eu.po patching file lightdm-1.4.0/debian/po/POTFILES.in patching file lightdm-1.4.0/debian/po/ml.po patching file lightdm-1.4.0/debian/po/es.po patching file lightdm-1.4.0/debian/po/zh_CN.po patching file lightdm-1.4.0/debian/po/pt.po patching file lightdm-1.4.0/debian/po/cs.po patching file lightdm-1.4.0/debian/po/gl.po patching file lightdm-1.4.0/debian/po/ta.po patching file lightdm-1.4.0/debian/po/nl.po patching file lightdm-1.4.0/debian/po/templates.pot patching file lightdm-1.4.0/debian/po/fi.po patching file lightdm-1.4.0/debian/po/fr.po patching file lightdm-1.4.0/debian/po/ro.po patching file lightdm-1.4.0/debian/po/el.po patching file lightdm-1.4.0/debian/po/ja.po patching file lightdm-1.4.0/debian/po/sv.po patching file lightdm-1.4.0/debian/po/ko.po patching file lightdm-1.4.0/debian/po/pt_BR.po patching file lightdm-1.4.0/debian/po/vi.po patching file lightdm-1.4.0/debian/patches/04_language_options.patch patching file lightdm-1.4.0/debian/patches/02_disable_tests.patch patching file lightdm-1.4.0/debian/patches/03_launch_dbus.patch patching file lightdm-1.4.0/debian/patches/09_lp577919-fix-chromium-launch.patch patching file lightdm-1.4.0/debian/patches/05_add_xserver_core_option.patch patching file lightdm-1.4.0/debian/patches/series patching file lightdm-1.4.0/debian/patches/01_transition_ubuntu2d_ubuntu_desktop.patch patching file lightdm-1.4.0/debian/patches/08_lp1059510.patch patching file lightdm-1.4.0/debian/source/format hejar@hejar-Studio-1555:~$ cd lightdm-1.4.0 hejar@hejar-Studio-1555:~/lightdm-1.4.0$ debuild dpkg-buildpackage -rfakeroot -D -us -uc dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2 dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2 dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro dpkg-buildpackage: source package lightdm dpkg-buildpackage: source version 1.4.0-0ubuntu2 dpkg-buildpackage: source changed by Michael Terry dpkg-source --before-build lightdm-1.4.0 dpkg-buildpackage: host architecture amd64 dpkg-checkbuilddeps: Unmet build dependencies: quilt libpam0g-dev gobject-introspection libgirepository1.0-dev gtk-doc-tools yelp-tools dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting. dpkg-buildpackage: warning: (Use -d flag to override.) debuild: fatal error at line 1350: dpkg-buildpackage -rfakeroot -D -us -uc failed hejar@hejar-Studio-1555:~/lightdm-1.4.0$

Could you explain how to install debuild from the package devscripts?


It seems that LightDM 1.4 is required for that greeter to compile and run, and Ubuntu 12.04 is running LightDM 1.2.

There is no LightDM ppa with version 1.4 for Ubuntu 12.04, so you'll need to compile it yourself. Maybe your best chance is download the source package from Ubuntu 12.10 and build it.

You will probably break your system doing this, so be careful. The same for the Unity Greeter. Instead of compiling from sources, download the source package and compile it. It will be much easier to return to a sane state if you start breaking things on your system by undoing the packages installations/upgrades. Here's the procedure:

Download the .tar.gz, the .diff.gz and the .dsc from Launchpad. Then, unpack the sources and build the package:

wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0.orig.tar.gz
wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.diff.gz
wget https://launchpad.net/ubuntu/+archive/primary/+files/lightdm_1.4.0-0ubuntu2.dsc
tar xzf lightdm_1.4.0.orig.tar.gz
gunzip lightdm_1.4.0-0ubuntu2.diff.gz
patch -p0 < lightdm_1.4.0-0ubuntu2.diff
cd lightdm-1.4.0

You might need to install debuild from the package devscripts as long as another dependencies.

After this procedure is completed, you'll have some .deb packages for LightDM ready to be installed on your system.

You might also run into some other dependency versions problem, and you might need to compile another packages as well using this method.

  • I need some more help for that re-edited the question. Please have a look. Thank you so much. Apr 14 '13 at 22:03
  • Here's the key, at the end: dpkg-checkbuilddeps: Unmet build dependencies: quilt libpam0g-dev gobject-introspection libgirepository1.0-dev gtk-doc-tools yelp-tools. You have to install that packages: sudo apt-get install quilt libpam0g-dev gobject-introspection libgirepository1.0-dev gtk-doc-tools yelp-tools Apr 18 '13 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.