Source Tarball. I started with the instructions found in the "INSTALL" file found in the extracted tarball and after I typed ./configure after which I received the error:

Configuring qbittorrent ...
Verifying Qt 4 build environment ... fail

Reason: There was an error compiling 'conf'.  See conf.log for details.

Be sure you have a proper Qt 4.0 build environment set up.  This means not
just Qt, but also a C++ compiler, a make tool, and any other packages
necessary for compiling C++ programs.

If you are certain everything is installed, then it could be that Qt 4 is not
being recognized or that a different version of Qt is being detected by
mistake (for example, this could happen if $QTDIR is pointing to a Qt 3
installation).  At least one of the following conditions must be satisfied:

 1) --qtdir is set to the location of Qt
 2) $QTDIR is set to the location of Qt
 3) QtCore is in the pkg-config database
 4) qmake is in the $PATH

This script will use the first one it finds to be true, checked in the above
order.  #3 and #4 are the recommended options.  #1 and #2 are mainly for
overriding the system configuration.

Checked the conf.log and it actually expects libtorrent to be available. The steps to be followed are here


I tried it myself and it works :)

  • I followed the guide you linked and I was A OK up til cd libtorrent at which point I received the error bash: cd: libtorrent: No such file or directory – BH2017 Apr 14 '13 at 15:04
  • What was the output of this step? svn co https://libtorrent.svn.sourceforge.net/svnroot/libtorrent/branches/RC_0_16/ libtorrent – thefourtheye Apr 14 '13 at 15:09
  • The program 'svn' is currently not installed. You can install it by typing: sudo apt-get install subversion oops rofl I oversaw this, I should probably run sudo apt-get install subversion. By the way how do I get the code I write in comments formatted the way your code is? – BH2017 Apr 14 '13 at 15:11
  • Updated the answer with the part of the same document which shows how to install required dependencies. Enclose the text with ` to highlight as code. – thefourtheye Apr 14 '13 at 15:16
  • OK I did what you said as far as following that guide and I got up to (under Compiling qBittorrent (with the Qt4 graphical interface)) ./configure at which point I received the same error as I put in my question. I have done all the building of dependencies mentioned in the guide but for some reason this didn't work. – BH2017 Apr 14 '13 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.