I get black tty screens when I hit Ctrl+Alt+F1. I already read all other similar questions but I can't seem to find a suitable solution.

Here is my setup.

I have a fairly new laptop (Jan 2013, Asus G55VW). It runs with EFI, came with windows 8. I wiped out windows 8 and installed Ubuntu Precise LTS. It has a Nvidia GTX 660M and I am using the 310.14 drivers.

I tried fiddling with the kernel boot options (nomodeset, agp=off, video=efifb, setting some obscure resolutions and mtrr options, etc...) as suggested by other threads. I tried the FRAMEBUFFER=y trick too... I tried booting without splash, or booting in safe mode, etc. nothing worked.

One funny thing though, when removing the "quiet splash" from the kernel boot options, after grub, the screen remains purple (default grub color) and I see black lines appearing one by one on the left, I guess these are the kernel messages that are not being diplayed properly.

In grub, I ran the videoinfo command and this is what it gave me:

List of supported video modes:
Adapter 'Cirrus CLGD 5446 PCI Video Driver':
  No info available
Adapter 'Bochs PCI Video Driver':
  No info available
Adapter 'EFI GOP driver':
  0x000 1920 x 1080 x 32 Direct ...

(typed it myself from a picture I took, so I shortened it a bit)

see the output of dmesg here: http://pastebin.com/1TJqehPR

In particular, note the following lines:

[    0.000000] No AGP bridge found
[    1.187154] vgaarb: device added: PCI:0000:01:00.0,decodes=io+mem,owns=io+mem,locks=none
[    1.187157] vgaarb: loaded
[    1.187158] vgaarb: bridge control possible 0000:01:00.0
[    1.233375] efifb: probing for efifb
[    1.237336] efifb: framebuffer at 0xc0000000, mapped to 0xffffc9000b700000, using 8128k, total 8128k
[    1.237338] efifb: mode is 1920x1080x32, linelength=7680, pages=1
[    1.237339] efifb: scrolling: redraw
[    1.237341] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    1.237426] Console: switching to colour frame buffer device 240x67
[    1.237454] fb0: EFI VGA frame buffer device
[   12.787856] nvidia: module license 'NVIDIA' taints kernel.
[   12.787858] Disabling lock debugging due to kernel taint
[   12.814355] nvidia 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[   12.814361] nvidia 0000:01:00.0: setting latency timer to 64
[   12.814364] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   12.814424] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  310.14  Tue Oct  9 11:52:41 PDT 2012

what should I do?

  • It is videocard driver related ... I have seen this before once but my install was borked (well I borked it myself ;) )at that time so I re-installed. I would start by going into software sources, additional drivers and try if 1 of the available options work for you.
    – Rinzwind
    Apr 12, 2013 at 22:38
  • I tried all the nvidia drivers in "Additional Drivers". I also tried with the latest driver downloaded from nvidia, but it didn't help Apr 13, 2013 at 19:19


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.