1

I'm using a Lenovo x230 laptop which features a touchpad and a trackpoint. I love the trackpoint and dislike the touchpad -- I continuously hit it with my thumb.

I would like to disable the touchpad, but leave everything else working. I've tried using xinput by putting the following in my .xinitrc:

$ xinput --disable 'SynPS/2 Synaptics TouchPad'

This works, however, after a few minutes, the touchpad becomes enabled again. I'm not sure why this is happening. Is this the best way to persistently disable the touchpad?

  • You should be able to use the answer provided there: askubuntu.com/questions/65951/how-to-disable-touchpad#67724 Best, – Victor Apr 12 '13 at 18:38
  • That is where I got this command from. However, the same thing happens: the touchpad gets re-enabled after a few minutes. – oneself Apr 12 '13 at 18:52
  • Are you on 12.04 or 12.10? – oaskamay Apr 12 '13 at 19:52
  • This is good to know, however I feel there needs to be a "disable-touchpad" setting under "mouse" to Automatically disable touchpad when a mouse is plugged in. Is this possible? – user149874 Apr 16 '13 at 21:33
4

The following methods will ensure your changes persist as long as you use gnome:

  1. Install and run dconf-editor (if you're on 12.10, dconf-editor might be pre-installed):

    $ sudo apt-get install dconf-tools

    $ dconf-editor

  2. Go to the following settings directory:

    org.gnome.settings-daemon.peripherals

  3. Under touchpad, uncheck the touchpad-enabled checkbox.

If you prefer not to meddle with dconf-editor's GUI, run the following command instead:

gsettings set org.gnome.settings-daemon.peripherals.touchpad touchpad-enabled false
  • Yes this will also work on 12.10 – Rinzwind Apr 12 '13 at 20:05
  • Perfect! I did not know that. I also edited my answer in case readers do not want to install dconf-editor. – oaskamay Apr 12 '13 at 20:06
  • It’s pre-installed on 12.10 and later. – AliNâ Apr 12 '13 at 20:12
  • sigh editing again – oaskamay Apr 12 '13 at 20:13
  • Works great using dconf. However, my system doesn't seem to have a "gsettings" command. – oneself Apr 14 '13 at 2:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.