I have a dell inspirion 5720 with Intel HD 4000 with Nvidia GT 630M, running ubuntu 12.10 64bit.

I installed bumblebee first, and worked, after that primus, and it worked again. After that I installed nvidia-experimental-310 (310.14) and changed both bumblebee.conf and the run file in /usr/bin/primusrun.

optirun runs fine and gained a 10 FPS boost but primusrun gives this error:

$ primusrun glxspheres
primus: fatal: failed to load any of the libraries: /usr/lib/nvidia-experimental-310/libGL.so.1:/usr/lib32/nvidia-experimental-310/libGL.so.1
libnvidia-tls.so.310.14: cannot open shared object file: No such file or directory
/usr/lib32/nvidia-experimental-310/libGL.so.1: wrong ELF class: ELFCLASS32

i dont know why. and i followed this : http://www.webupd8.org/2012/12/use-nvidia-experimental-drivers-310.html

here are my conf files: bumblebee.conf: http://pastebin.com/tL0FVern /usr/bin/primusrun: http://pastebin.com/tP4PJpQS

  • I don't have experience with bumblebee, but i recommend to look at this. It is the new nvidia driver with optimus support ;). devtalk.nvidia.com/default/topic/539249/… – Thomas15v Apr 12 '13 at 18:57
  • I know about it, but i read it its still just initial support, and right now bumblebee has better support, so i wish to use bumblebee. – NaGeL182 Apr 12 '13 at 19:18

I don't know why this works, but I had the same problem and it worked when I did not replace the second path in the primus config file.

So I just used:

export PRIMUS_libGLa=${PRIMUS_libGLa:-'/usr/lib/nvidia-331/libGL.so.1:/usr/lib32/nvidia-current/libGL.so.1'}

or in your case, replace with:

export PRIMUS_libGLa=${PRIMUS_libGLa:-'/usr/lib/nvidia-experimental-310/libGL.so.1:/usr/lib32/nvidia-current/libGL.so.1'}
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.