The other day I applied updates and broke my ability to watch amazon videos on my computer. I am not alone. See the amazon forum post.

How can I rever to the previous version of Flash?

Here's what I've tried so far. Using

tail -10 /var/log/dpkg.log

I found this line that looks like the culprit on my system:

2013-04-10 16:31:56 status installed flashplugin-installer:amd64

At this point, I'm not sure what to do. And I think the issue is complicated by the fact that the package I'm referring to is an installer, not an actual plugin.


Here is the fix:

  1. Close running instances of your browser.
  2. If you don't already have synaptic package manager installed (it isn't by default) install it. From the terminal type:

    sudo apt-get install synaptic
  3. You will also need to install "hal" and "hal-info", unless already installed:

    sudo apt-get install hal hal-info
  4. Start Synaptic Package Manager
  5. In the top right of the application is a search box. Search for "flashplugin-installer"
  6. Highlight the package and press Ctrl + E
  7. The "Force version" window should open
  8. Pick version instead of the currently installed
  9. Apply changes by clicking the button that says "Apply" with a check mark under it.
  10. With the package still highlighted, select from the top menu: Package->Lock Version
  11. Close Synaptic and open a terminal
  12. We need to remove old cached versions of the plugin. First type:

     cd ~/.adobe/Flash_Player
  13. Next type:

     rm -rf NativeCache AssetCache APSPrivateData2
  14. You can now close the terminal and reopen your browser

Thanks to Rob S for the instructions on how to do this. The above instructions are his with only slight modifications. Additionally, the last few instructions are from the Arch Linux Wiki.

  • When you quit synapic, it'll ask you quit and discard changes. I think that's because you've downgraded the package. – Dror Apr 13 '13 at 8:51
  • I have tested these instructions and they work for 12.10. I believe they should also work for 12.04. I haven't been able to get them to work for 13.04. For 13.04 they fail at step 6 where "force version" is disabled. Any suggestions on how to fix? – snowguy Apr 27 '13 at 6:38
  • 13.04 question here has the answer: askubuntu.com/a/289341/4462 – aap May 2 '13 at 3:56

I use the adobe-flashplugin package instead of the flashplugin-installer package, so I fixed it a different way; I downloaded the old .deb file for the adobe-flashplugin package and installed it with dpkg:

wget http://launchpadlibrarian.net/134077901/adobe-flashplugin_11.2.202.275-0precise1_amd64.deb
sudo dpkg -i adobe-flashplugin_11.2.202.275-0precise1_amd64.deb

I'm using 12.04 (precise); you can find the appropriate download urls for other ubuntu releases by following the links here:


One big drawback to doing it like this is that apt-get will refuse to install or update any other packages until you upgrade your adobe-flashplugin package back to the latest version with this command:

sudo apt-get -f upgrade adobe-flashplugin

Hopefully amazon fixes their flash player soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.