Recently Intel released their opensource driver tool (https://01.org/linuxgraphics/downloads/2013/intel-linux-graphics-installer) which auto-selects the right drivers for your intel chipset (in my case, I was using the i915 driver). Because I started using Steam on Linux to play some older games I thought I would use the Intel 'official' drivers to ensure I get the best performance. Unfortunately, since installing the drivers, the computer fan is very loud and the battery doesn't last that long (it's cut battery life in half). On top of that, there's no noticeable difference when playing games on Steam.

My question is, how do I revert back to the original drivers?

If I run the Intel graphic driver installer I get the following output in the terminal (not in the GUI) so I assume I will somehow need to run apt-get with some type of downgrade flag (I'm not sure how to do that) against these packages.

install: [i915-3.4-3.2-dkms libdrm-nouveau2]
upgrade: [libcairo2 libcairo-gobject2 libcairo-script-interpreter2 libdrm2 libdrm-intel1 libkms1 libva1 libva-x11-1 libva-glx1 libva-tpi1 libva-egl1 vainfo libxatracker1 libgbm1 libegl1-mesa libegl1-mesa-drivers libopenvg1-mesa libgles1-mesa libgles2-mesa libglapi-mesa libgl1-mesa-glx libgl1-mesa-dri libgl1-mesa-dri-experimental libosmesa6 libglu1-mesa i965-va-driver libva-intel-vaapi-driver xserver-xorg-video-intel libwayland0]

When I look at the install logs though, it seems there's much more than that.

Any assistance on this would be most appreciated.


6 Answers 6

sudo apt-get autoremove --purge intel-linux-graphics-installer

A solution from http://www.liberiangeek.net/2013/04/how-to-add-intel-linux-graphics-driver-repository-in-ubuntu/

  • 2
    I'm afraid that would only uninstall the installer, but not the drivers and dependencies originally installed by it
    – unfulvio
    Mar 31, 2016 at 17:01
  • 2
    The package is no longer named so. I get E: Unable to locate package intel-linux-graphics-installer
    – Yalok Iy
    Apr 16, 2017 at 14:29
  • 2
    Now the package is named intel-graphics-update-tool so the full command is sudo apt-get autoremove --purge intel-graphics-update-tool and it works for me.
    – luke
    Jan 15, 2018 at 10:36
  • yep, it's confirmed sudo apt-get autoremove --purge intel-graphics-update-tool works Apr 2, 2018 at 6:19

This is what worked for me:

#source http://theclonker.de/?p=89
sudo sh -c 'echo "\nPackage: *\nPin: release a=trusty*\nPin-Priority: 1001\n\nPackage: *\nPin: origin download.01.org\nPin-Priority: -100\n" > /etc/apt/preferences.d/intel-removal'
sudo apt-get dist-upgrade
sudo rm /etc/apt/preferences.d/intel-removal
sudo rm /etc/apt/sources.list.d/intellinuxgraphics.list*
sudo apt-get update
echo "\n\n\n\n\n\n Remember to remove the i915-3.6-3.5-dkms and intel-linux-graphics-installer packages with \n\n sudo apt-get purge i915-3.6-3.5-dkms intel-linux-graphics-installer "

You should change the i915-3.6-3.5-dkms package name to your version.

Source: https://gist.github.com/phdelodder/b28e8df770a6bc020aab

The original source http://theclonker.de/?p=89 was removed.

  • 1
    Note the way to find your current i915-dkms version so that you can apt-get purge it is to run: dpkg --get-selections | grep i915 Sep 4, 2016 at 2:19

Here is a possible solution to your problem http://theclonker.de/?p=89

  • thanks a million! I'll try this later tonight. Hopefully I'll not destroy my system in the process :)
    – rimez
    Apr 12, 2013 at 7:25
  • Hopefully your system will be ok :) I have tried those steps and it solves mine. Btw, I am using ubuntu 12.10
    – Asraf
    Apr 12, 2013 at 7:32
  • I did a thorough review, it seems that this method will only replace the actual driver without uninstalling the MANY dependencies which were installed.
    – rimez
    Apr 12, 2013 at 8:56
  • 2
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Apr 12, 2013 at 9:12
  • Guys.. this question can be closed. I got fed-up with this issue and decided to do something a little drastic - I simply upgraded to 12.10. It's resolved my issue for now.
    – rimez
    Apr 12, 2013 at 13:43

In the end I found this to be too frustrating to wait for the right answer. In order to fix the situation, I upgraded to version 12.10. It completely wiped all traces of the Intel drivers and I now have a quiet and cooler laptop.


The easiest solution is to use the ppa-purge tool:

sudo ppa-purge -s download.01.org ppa:gfx/ubuntu

This will disable the intel repository and downgrade all packages that were installed from this repository.


In later versions the name has changed; to remove you need to run the following:

sudo apt autoremove --purge intel-graphics-update-tool

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .