1

I've talked about my laptop's touchpad elsewhere...

HP G42 touchpad

Given its touchpad position and configuration you trigger the secondary and terciary click while typing as they are bound to the Left Top and Left Bottom corner*.

I know how to fix this(** , ***), I have this:

# Example xorg.conf.d snippet that assigns the touchpad driver
# to all touchpads. See xorg.conf.d(5) for more information on
# InputClass.
# DO NOT EDIT THIS FILE, your distribution will likely overwrite
# it when updating. Copy (and rename) this file into
# /etc/X11/xorg.conf.d first.
# Additional options may be added in the form of
#   Option "OptionName" "value"
#
Section "InputClass"
        Identifier "touchpad catchall"
        Driver "synaptics"
        MatchIsTouchpad "on"
# This option is recommend on all Linux systems using evdev, but cannot be
# enabled by default. See the following link for details:
# http://who-t.blogspot.com/2010/11/how-to-ignore-configuration-errors.html
      MatchDevicePath "/dev/input/event*"
EndSection

Section "InputClass"
        Identifier "touchpad ignore duplicates"
        MatchIsTouchpad "on"
        MatchOS "Linux"
        MatchDevicePath "/dev/input/mouse*"
        Option "LTCornerButton" "0"
        Option "LBCornerButton" "0"
        Option "Ignore" "on"
EndSection

# This option enables the bottom right corner to be a right button on
# non-synaptics clickpads.
# This option is only interpreted by clickpads.
Section "InputClass"
        Identifier "Default clickpad buttons"

In my /usr/share/X11/xorg.conf.d/50-synaptics.conf file. And it should work as setting those options with synclient but ubuntu decides for some reason that I knows better and I can't override the setting.

Why? and, most importantly, how can I fix this?

Also: this question is a possible duplicate of X11 ignoring options in configuration for input device but that solution is ugly. I won't do that, but should I post this as a comment?

*: They will be triggered at the worst time, like, ALL THE TIME. Enough to drive me mad...

**: Where is the X.org config file? How do I configure X there?

*** http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html

  • Have you tried /etc/X11/xorg.conf instead of the file in /usr/share...? And how is that solution ugly? It works and it will keep working regardless of xorg.conf problems. You can even put the script in your personal Autostart instead of in the lightdm session files. Maybe you should file a bug about this. – blujay May 5 '13 at 5:27
  • It's ugly because it relies in a bash script to work around the issue instead of the proper way of getting the settings right. Why would I try /etc/X11/...? – tutuca May 5 '13 at 13:36
  • 1
    @blujay it's useful yes, but in my experience, the settings don't stick through the x-session's lifespan. You frequently have to rerun the script. It drives one mad. – djeikyb May 6 '13 at 17:11
1

I was having the same issue on Linux Mint 15. Try the solution on this link. It worked for me: https://askubuntu.com/a/122589/165847.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.