4

I try to do a "@" but each times a press on Alt+2 or Ctrl+Alt+2 to get it, the Top menu of the app/windows show off (File/Edit/View/Tool...)

If a try with a English Canadian's Layout or a English USA, I got the same problem.

On Lubuntu or Xubuntu 12.10, I don't get this problem. That really seem to come from Unity's Shortcut. I am Using Ubuntu 12.10.

  • I edited your question, please tell me if the structure is fine. So, the problem is that you can enter @, but it make an ugly behavior in the screen, right? When you say Alt, are you talking about Alt Gr? Because this keys are slightly different. – Lucio Apr 12 '13 at 0:22
1

I think it is Ctrl+Alt+2, is it?

| improve this answer | |
  • Normally, Yes. But each time I press on ALT, the top Menu appear on the Windows/Application (File,Edit,View...) – Kamikazz00 Apr 11 '13 at 23:33
  • @Kamikazz00 In Unity, the HUD (not the menu, except in Opera and few other programs) would normally deploy if you release the ALT (not ALT GR) key before pressing any other key. – carnendil Apr 11 '13 at 23:42
  • I remove this function of the HUD because I thinked he was the problem and nothing change! But I just found if a press on ALT GR + 2, I can now write @ – Kamikazz00 Apr 11 '13 at 23:59
  • 1
    @carnendil If you disable the HUD ALT focuses the menu bar and doesn't work for shortcuts.. I think this is a known bug. – Seth Apr 12 '13 at 14:29
  • @Seth Thank you, this is something I didn't know (and with 12.04 I forced myself to get used to the HUD) :) – carnendil Apr 12 '13 at 16:23
1

In Ubuntu 12.04, (right alt key)+'2' does it for me with my french canadian keyboard.

| improve this answer | |
0

Check/change/adjust the actual combination of keys in your current layout from the Keyboard layout configuration. More info this answer.

It's possible (I don't use a French Canadian layout) that you have to use Alt gr (left side of the space bar) instead of Alt.

| improve this answer | |
  • Thanks for the Comment but the guys is stuck at exactly the same place than me, He can't do @ and #... – Kamikazz00 Apr 11 '13 at 23:37
  • If I use ALT GR + 2, I can do @ – Kamikazz00 Apr 12 '13 at 0:01
0

E.g. you can:

  1. run gucharmap
  2. find whatever symbol you need
  3. double click it
  4. click on Copy button in the lower right corner
  5. paste the symbol wherever you want it

For a bit more convenient way:

  1. press ctrl+shift+U keys
  2. release U
  3. enter hexadecimal unicode sequence of the symbol you want while still holding ctrl+shift
  4. release ctrl+shift

Unicode for @ is 0040 (so you need to type in 40 before releasing ctrl+shift). You can find other unicode sequences in gucharmap.

You might want to tinker with System Settings -> Region & Language -> Layouts, you can choose desired layout there and configure it's options (Options button in lower right corner of the window), however, I couldn't find anything related to @ - maybe it's layout specific.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.